Red Light of ?


New Member
May 14, 2012
Reaction score
Hi everyone, I have an issue that nobody seems to be able to help with.
I have a brand new Xoom 2 (literally only had it 3 hours) after going thru the usual process of installing basic apps, I installed Firefox.after it installed, the screen went blank and will not come back. Just before it died I connected to charger as unit was down to 5%. Now when I hold the power button, I get the top led flashing 3x (popular theory is battery is to flat to boot) so I connect charger, and I get the steady white charging indicator light but also a steady red light at the top. I have tried the soft reset and all I get is the top led 3x. I cannot do a factory reset as I can't get as far as the Motorola logo and go thru the menu. I have spoken to the eggheads at Motorola, and they have no idea what the top red light indicates. I am of the opinion that the steady red light indicates an issue with the charge cable, but can't confirm as I don't have another one to try at this point in time.
Has anyone else had a similiar issue or can confirm this?
it worked for me!

If this is still an issue, I've just had much the same problem. It SEEMS like the battery was COMPLETELY drained and even the charger wouldn't get it going again! Using a USB cable to give it some initial charge seems to have done the job - and then I was able to change to the proper charger.

You might be able to get at the thread about this at Is my Xoom2 dead?