Razr maxx ics update from rooted gingerbread 2.3.6


New Member
Sep 24, 2012
Reaction score
There's a lot going on, so I'll try to lay it out as cleanly as possible.

My main goal is to be able to use my Droid Razr Maxx in the Bahamas using a local Bahamian Sim Card on the local GSM network. We moved here in July 2012 as missionaries, and I would like to be able to use my current phone instead of buying a Bahamian phone.

Note: there is a tool we have here that cuts a regular sized sim card to make it fit the micro sim card slot in the Razr Maxx.

About my phone: My Razr Maxx is currently running Gingerbread 2.3.6, but I rooted it back in the USA before we moved. I rooted this phone with the tutorial at droidrazrroot.com. My main purpose in rooting the phone was to get the free WiFi hotspot. So I never installed a custom ROM. I did install BloatFreezer to clear some bloatware out.

I never updated to ICS because the update was made available after we moved. And since we moved away from the USA for good, we cancelled our verizon service. So I wasn't too concerned about updates, I just figured my phone was an expensive toy from now on.

So I have a rooted Razr Maxx with Gingerbread 2.3.6, with no service.

But then I read that the ICS update unlocked the GSM radio built into the Razr Maxx. So now I am interested in trying to get my phone to work on the local GSM network with a local sim card.

When I go to Settings > About Phone > System Updates and download the latest update, it runs the update until it tells me that "The Update has Failed". Twice it has done this.

My first question: Do I need to Unroot my phone BEFORE I update to ICS?

My second question: Can I update my phone to ICS without having Verizon (or any carrier) service? Or do I need to be connected to Verison's network to run the ICS update?

My Third Question: If I can't update to ICS without having carrier service, is there a way to unlock the GSM radio feature in the current state of my phone, a rooted Gingerbread 2.3.6? I ask this third question because root access allowed me to manipulate the WiFi hotspot settings, and I thought that root access might allow me to manipulate the GSM radio feature. If I can turn on the GSM radio with root access in 2.3.6, how is this done?

Thanks, and I hope you were able to follow my timeline.
What did you do? I have a rooted Gingerbread Razr Maxx and I am trying to get the ICS update to successfully install.
First, I had to uninstall all of my "root" apps, like Safestrap, Bloatfreezer, etc.

I got hung up the first time I tried updating because I uninstalled Safestrap before I stopped it's recovery service. So, if you have any sort of backup app, make sure you stop the backup service before you uninstall the app. My problem was when I uninstalled Safestrap, it left the recovery portion of the app in tact and running on my phone. I thought a factory reset would cure this, but it didn't. So I had to re-root, re-install Safestrap, cancel the recovery portion, then uninstall Safestrap, and finally unroot again.

Once completely unrooted with all of my "root" apps uninstalled, the update worked flawlessly.