Problems connecting RAZR (Maxx) with Alpine Stereo Bluetooth

Hello everyone!

Just put this head unit in my car today. Luckily I'm not having most of the issues here. however "everytime I select the pandora option, I have to acknowledge the access key request that pops up on the phone, but after that it'll work great until I turn off the stereo or car engine (I'll have to redo it again when I turn the ignition)." is happening to me. I've got a droid 4 rooted stock. I'm gonna try my CM10 rom (which I can't use as a daily driver due to other issues in the rom), and I'm gonna try a few other device (N7 stock, D3 stock and CM10 / 9, D1 CM7, stratosphere whatever's on it).

Hopefully I can figure out where the blame lies (motorola or alpine). I might have to dive in to the bluetooth spec to see what the behavior is supposed to be. What is actually causing the issue is that the head unit switches passkeys every time it starts. If it keeps the same passkey, I don't think there will be any problems.

edit: some quick research (before testing) found this: Pairing_WP_V10r00.pdf
It looks like devices are only supposed to generate the passkey when pairing, and not during every connection. This seems obvious, due to the security risks associated with generating a new key every connect. I'm hoping that by finding out which device doesn't comply with bluetooth standards, we can force the manufacturer to release an update (or lose their bluetooth certification). Otherwise, I doubt anything will be done to fix this.

edit 2: OK, I did some testing. Verdit: bugs abound. My nexus 7 worked fairly well, and reconnected automatically after power cycling the car, so this leads me to believe that the head unit is complying with the spec (unless android has a hack to get this sort of thing to work). The droid 3 was pretty much the same as the D4 stock. The custom rom didn't really support bluetooth. I also tested an HP touchpad, which couldn't connect to pandora (it's running a really old CM9 version, so understandable that it doesn't have good bluetooth support). The droid 4, I tried a few custom roms: the latest CM10 build from hashcode, which didn't work for pandora (can't remember audio though), the december 17th CM10.1 build, which couldn't even turn on bluetooth, and lastly, the 1-16 build of CM10.1 (ooh, two newer builds, I'll try the latest tomorrow), which worked flawlessly! (well, the bluetooth did. Every time I recieve a call, phone crashes, rings forever, and I have to hard boot the phone. unfortunately, this is a bigger issue than the bluetooth one, so I'm stuck on stock until this is fixed. I'm contacting hashcode to see what I can do).

I have not yet tested the stratosphere and the droid 1 (they were dead). I think the stratosphere will be the most telling: if it works, it's a motorola issue. If not, it's something alpine might want to fix.

I also found a few bugs on the Alpine side though. First, when trying to 'clear' (which is actually unpair) a device, the head unit seems to need to connect to the device first. That's a problem if you already removed the pairing on a target device. I had to reset my radio to get rid of the device. Second, when a bluetooth device tries to connect to the radio while the radio is connected to a different device, the connecting device will give a passkey error (the head unit is probably trying to use the passkey of connected phone). Alpine should either disable discovery during this time (and make sure searching works) or fix it to be able to handle two passkeys simultaneously. The former seems much easier. Third, after a reset, the radio takes a while to start up. However, it finishes loading the main screen and the first level of menus before it's actually done. When I went into the main menu, I couldn't actually click on anything until it finished booting. I thought my knob was malfunctioning.
Last edited:
Don't ya just love how this went through such exceptional Q/A before being released for resale.... :frown:
My thoughts exactly on the QA.

I tried the latest rom for my D4 (CM10.1 1/19) and it works great. The head unit reconnects without issue, and the phone doesn't crash when I get calls (I somehow missed that CM10.1 is still an early beta for the D4, whoops). This will now be my daily driver ROM.

I also tested my Droid 1 with CM7 on it. It worked flawlessly, and the head unit was able to reconnect without issue.

Unfortunately, I was unable to test the stratosphere because it couldn't connect to the play store to update pandora or google music, and couldn't actually stream pandora either.

However, I am led to believe that since this works in non motorola stuff pretty reliably, it is a motorola issue and not an alpine issue. If you've got a moto device, I'd suggest trying the latest CM10.1 from hashcode to see if that works for you, and is stable enough (and has enough functions) to be your daily driver.
Last edited:
Ok here is what I have found that may or may not helps some of you. I have the RAZR MAXX and had ICS 4.04 and the radio was pretty much useless for Media BT. I manually upgraded to Jellybean 4.1.2 today and it has fixed 80% of the problems. I now can stream Pandora and Tune in Radio over BT without a problem and make voice command phone calls and it returns to BT audio. Not much luck with the Pandora selection it won't launch Pandora or even find the phone most of the time. I have seen a few glitches when transferring back off phone to BT but it seems to recover quickly and I am able to use my se3lection arows on BT audio to FF through the Pandora songs. Hope this helps and just a little further info I manually updated to JB and have not rooted my phone.
Well I'm glad I found this thread!

I bought the CDE-HD137BT yesterday and found that after I would turn the car off then back on i would get a pair request confirmation on my phone. The request disappears after a few seconds, so if you miss it you have to go all the way in to Bluetooth settings and press on the Alpine Audio Receiver item to reconnect. Other then that the unit works perfectly with Pandora, GPS and phone calls with my Droid Razr Maxx running ICS 4.0.4 build number 6.7.2-180_DHD-16_M4-31. So last night I did the Bluetooth update provided by Alpine which didn't change a thing and was a royal PITA if you ask me (why can't we just use USB). So today I called Alpine and was told very quickly that you have to set the radio to HD-Radio mode before shutting the car down. This will cause the phone to connect as a head set first and audio device second. Now this sounds a bit fishy to me, but I am going to try it after work and will report back. Honestly I don't see how this is going to work as the pin code is different every time I have to click "pair" when the radio turns on. However, I will give it a try as soon as I get out of work. I really just want the thing to work as it should. I want to get in the car, turn on the radio and do nothing else and have Pandora start to play. There has to be some fix/update that will correct this. Whoever it was talking about the pin being different every time I can confirm with mine. Any idea which side this issue belongs to so I can start pestering the hell out of them?
Well I'm glad I found this thread!
I really just want the thing to work as it should. I want to get in the car, turn on the radio and do nothing else and have Pandora start to play. There has to be some fix/update that will correct this. Whoever it was talking about the pin being different every time I can confirm with mine. Any idea which side this issue belongs to so I can start pestering the hell out of them?

I believe The BT sync is the phone, ever since I upgraded to JB no problems with Bluetooth Audio. I still have a problem with the Pandora Radio app so I disabled it and now only use the BT audio and have not had a problem in months, Select Pandora or TuneIn whlie walking to the car and everything works like a champ, voice dial and phone and back to BT audio no problem.
Ya I'm of the belief that you just have to deal with the issues as they are, no one is going to fix this problem .............. :(
any update on this ? I have the 138bt and the random passcode issue. its like BT Pandora is a completely different channel or protocol all by its self .
I talked to a Verizon tech today and he was very excited ( u know how bored they get) and we talked for 30 min, he even remoted into my phone. said he will look into it some more and file a report to his boss.