Problem with contact's primary method of communication


New Member
Aug 30, 2010
Reaction score
Wooster, OH
Phone: HTC Droid Incredible
I have a group with 15-20 contacts in it, to whom I send messages. I created the group then searched for and added contacts as members of the group. When searching for the contacts, it didn't give me a list of numbers/methods for that contact. It was just the person's name, I tapped it, and it was added.

This past Friday I started sending messages to the group. Sometimes I would get "undeliverable" texts in return, and then I would hear from some group members that they did not receive any texts only to find out later that they had gotten sent to their email address.

Basically I want to be able to select the appropriate contact entry for each member to ensure my text messages get sent to their phones instead of their email addresses. I've searched already and have found how to change this (supposedly), but it doesn't work on my phone. Thank you for any assitance.
Let me see if I can get this moved to the Incredible section.

Maybe I was not explaining my issue very well.

I now have 3 contact groups I send text message updates to (used to be 2, but now max contacts per text is 10 with Froyo 2.2). When I am editing a group and I go to add contacts, I can search for a name, then tap on the name to add that person to the group. Or if I'm editing a person's contact, I can choose the appropriate group from the Group drop-down menu.

HOWEVER, it does not give me the option to select which contact ENTRY for that person I wish to use on that group. When I got to send a text message to the group, if that contact has a mobile phone number and an email address, it sends the person an email instead of a text message. The contact has "Call mobile" set as Primary as well as "Send mail" set as Primary (yes, there are 2 Primary's). The other option NOT set as Primary is "Send message" which is what I want.

How do I set "Send (text) message" as the Primary contact method for a contact? Also, is it possible to set this as the default setting for any/all contacts? If I am viewing a contact, I press and hold on Send message like I've read, but nothing happens. If possible, I would like to remove Primary from the email and change the other Primary to "Send message".

Please help. I need this fixed by Friday. Thank you.

OR... Is this just something that Droid "does" NOT do?
did you ever get an answer on this? how to chose your own primary option on a contact?
I got my 2.2 update yesterday. It looks like this may have been resolved with version 2.2. It is sending text messages to a mobile number. If there is more than 1 mobile, it's sending to the Primary mobile (which is easy to set, as long as there's more than 1). One thing I read about was doing the following: Open the Group. Open a contact. Tap Menu > More > Set widget action. When doing this, you can select a specific contact entry. However, what "widget" does this refer to? I got the 2.2 update AND did this for each contact on my groups, and it is working like a charm! I'm not sure which actually fixed it, the 2.2 update or picking the widget action for each contact... but it works now.