PLEASE HELP!!Su binary not installed and SuperSu cannot install it.


New Member
Feb 11, 2014
Reaction score
I have Xperia U awhich i had rooted with Root_with_Restore_by_Bin4ry_v18 withouth unlocking the bootloader.

Recently my phone failed to start at the screen got stucked on the Xperia logo so i had to repair the installation by updating the phone with ICS from update service.

After that my phone seems to be half rooted, it installs the root apps like SuperSu , busybox but it has lost the su binary files.

The SuperSu gives the error 'Su binary not installed and SuperSu cannot install it'. I know this is a common problem i searched a lot on it and the best solution i fiund was to flash the SuperSu zip file from Clockwork Mod recovery.

But i dont have CWM as i didnt unlock my bootloader while rooting and i tried to install it but it didnt get installed as there was no su binary.

I cant un-root my phone i cant re-root it. I have tried everything but nothing works.
Is there no way i can have root access again?