Parts of touchscreen failing


New Member
Jul 6, 2011
Reaction score
Droid 2, not rooted

The other day when I went to go open my applications, the little "arrow" at the bottom center of the screen was unresponsive to my touch. No matter how many times I pressed it, it either went to the call option, or my contacts. I eventually gave up, rebooted it, and the problems continued, and I just went without my apps.

The following day, I rebooted it again, and to my complete happiness, it worked. However, the unresponsiveness moved over, about a half an inch to the left, so now the entire 2nd "column" (the home key upward) doesn't work and is unresponsive. If I hold down the applications in the same column, it allows me to move them, but just touching them to get them to open, fails. So I guess it is still somewhat receptive? It has been getting worse, the more I use it though. And yesterday I was unable to unlock my phone since the "slide to open" function, failed to slide completely across the screen. It also happens that the unresponsive column is directly on the answer button, so I can't get anyone's calls, and the Home key doesn't work either. So I have to hit back a lot whenever I'm in any app.

I was able to work around it, by turning the phone, and opening and closing the keyboard for the first couple days, hoping it would go away, but it's become really frustrating. I've rebooted it multiple times, and factory reset it about a half hour ago, but the same problem persists. Any ideas?
I had the same problem. Its the digitizer failing. The only way I fixed it was replacing the digitizer, which requires you to disassemble the phone entirely. you can get new digitizers for 20-30$, but it is kindof a pain to replace.
Good luck!