Not receiving GMAIL

skennelly

Active Member
Joined
Oct 27, 2010
Messages
577
Reaction score
30
Location
Illinois
I am not receiving gmail in a timely manner. It only pulls new mail when app is opened, menu, and a manual refresh is done. Very annoying, got emails at 9 PM last night that were sent at 9 am, 11am and 3 PM. I notice that the settings menu is different for gmail than it is for my Live and Hotmail accounts.

If I go to settings > data manager > data delivery (Background data enabled, data enabled) > Email and Corporate sync (Data push checked, fetch 15 min) sync over wi-fi disabled.

I notice there is an option for default email account. If opened it only shows Live and Hotmail. GMAIL is not even listed...I think here in lies the problem. It seems as though my X does not even recognize gmail as an email account.

Any thoughts?
 

jack902902

Member
Joined
Sep 21, 2010
Messages
63
Reaction score
1
Location
FL
Very similar problem here! Got no emails all day, got home and it started hitting me. The only thing I did when I got home was turn on my WiFi.
 

DxExs

Member
Joined
Oct 29, 2010
Messages
32
Reaction score
0
Having similar problem here. Are you using juice defender or other app that manages internet?

Sent from my DROIDX using DroidForums App
 
OP
skennelly

skennelly

Active Member
Joined
Oct 27, 2010
Messages
577
Reaction score
30
Location
Illinois
They problem has been going on before I had installed juicedefender, but have deleted app and still have the problem. I have even put phone on performance mode and that doesn't work. Other email accounts sync fine, only gmail has the problem.

Does everyone else that has multiple email accts have the same info in their settings that my phone has, or can gmail be activated as default email?
 

hookbill

Premium Member
Premium Member
Joined
Nov 30, 2009
Messages
19,372
Reaction score
9
Location
N.E. Ohio
They problem has been going on before I had installed juicedefender, but have deleted app and still have the problem. I have even put phone on performance mode and that doesn't work. Other email accounts sync fine, only gmail has the problem.

Does everyone else that has multiple email accts have the same info in their settings that my phone has, or can gmail be activated as default email?

You can indeed use gmail as your default email client. Go over to your gmail account and look at the settings. You can have your other accounts pushed through gmail, but I will let you know right now that it sometimes takes an hour before gmail will push it. Sometimes less.

Any reason why you can't use both gmail and your email client?

For the record, my gmail is working great. I've been getting mail all morning.
 
OP
skennelly

skennelly

Active Member
Joined
Oct 27, 2010
Messages
577
Reaction score
30
Location
Illinois
Gmail > menu > more > settings does not have option to make gmail default email.
Gmail > menu > accounts > gmail (1 accounts with option to addie acct) > menu button > settings takes me to data manager, again with gmail not listed as an available option as default email (only live& hotmail).

I know I may be anal about this, but each account is used for different purposes and it has been frustrating that when gmail syncs there are emails from 12 hours prior finally being delivered.

@hookbill in your data manager settings is does it list gmail along with any others you may be using as an option for default?
 

kevinkar

Member
Joined
Sep 23, 2010
Messages
300
Reaction score
0
I have my primary Gmail address as the main mail account on my Droid X and I have our general home Gmail address (bills, and accounts and stuff) as a secondary mail account on the phone and I just sent two separate test mails from work to each address and they both showed up in less than 20 seconds on my phone.

I simply added the accounts according to the prompts on the phone and didn't really change anything. So, by default, the phone seems to get mail as soon as it arrives.
 
Top