No USB notification or connection (other than charge)


New Member
May 28, 2010
Reaction score
Grrrrrr. Trying to get tethered up but seem to be getting lathered up instead.

I've got Liberty 2.0 and XP 32 bit SP3 on the desktop. The DX charges but I don't get the USB bong sound on the desktop or the notification on the Droid when I plug it in. I've downloaded the Motorola help thingy that's supposed to install the USB driver and I've installed EasyTether. I've uninstalled both and reinstalled them, with and without USP debugging activated. I've performed the repair function on the Motohelp thing (whatever it's called - I"m at work using a computer that can actually get online so I can't remember the mame of the installer). I've pulled batteries (and hair out) both with USB debugging on AND off, done restores, checked the USB port with a multi-card reader, which works just fine (that's how I transfered the EasyTether and Moto thing).

Funny thing is, I've seen the USB notification and heard the USB sound when plugging it in just in the past day or two but I can't really say what I've done since then, except to say that I've been in the reboot/recovery mode on the Droid because I was fiddling around with the Liberty Toolbox and accidentally set it to boot into recovery (I've since changed that <g>.) Basically, I chose backup and restore (I think). But I've uninstalled and reinstalled both EasyTether and Moto since then. I"m thinking that I've changed some sort of configuration in the bowels on the machine. Other than this, the DX works perfectly under Liberty and overclocked at 1.2 (the "low voltage" setting). I just took it back to stock at reboot to see if that would make a difference. It didn't.

Anyway, I can't figure out what's going on. I tried the cable on this machine and got the same result (charge but no actual USB love.)

I"m going to be back on the DX later, so I"ll be checking back in later if anyone's got any ideas...oh yeah, found several threads on this phenomenon through search (on several forums, including the Droid forum here, but nothing has helped so far...)
I got the same issue with my evo 4g. Plugging in usb cable doesn't raise any notification that would permit me to change the usb mode. Setting default to disk drive doesn't help. Setting the checkbox to ask me doesn't work.
Also: doesn't work on my home linux system either.

Booted to recovery mode and selected mount usb and I was able to see the evo's sd card. This rules any possibility that it is a hardware or windows issue.