No Data Connection Despite Strong 4G Signal After Flashing ROM


Apr 4, 2010
Reaction score
For the past few days, up until today, I have been running Scott's SenseLESS ICS 2.0 (and 2.1) ROM on my Rezound. Except for the known, reported bugs, everything else was working great.

Today, I saw that Ineffilibis had a Sense-Less ICS 4.0.3 ROM, so I downloaded and gave it a shot. (Wiped data, etc, usual procedure). After it rebooted, I tried logging in to Google, and the phone hung on the login screen, and finally, "Connection timed out". Tried this several times before giving up and restoring my backup of Scott's ROM.

When the restore completed, I rebooted, and noticed that although I had a strong 4G signal, my phone would not connect at all for data (and data, as well as autosync are turned on). Could not get to the market; only "Connection timed out" after several minutes. Browser also would not connect. The back of the phone is closed tightly, so I know it's not the antenna; plus I have a strong signal. I also tried flashing a different kernel by copying a PH98IMG.ZIP file from Scott's downloads section, but that did not make a difference. Also, while connected via USB, I noticed that most of my internal storage has been wiped out somehow--don't know how that happened, because although I did wipe data via Amon Ra before flashing the Ineffilibis ROM, that never erased all my internal storage before.

Right now, I'm just trying to get my data connection back. Any ideas are greatly appreciated! I will deal with this more tomorrow. I hope this all makes sense to someone--I am exhausted right now--time for bed!


**EDIT** I think I found part of the problem. I think my SIM card may have somehow gone bad. I pulled the SIM and will leave it out for a while and see what happens.
Last edited: