New Xposed Module Hides Root

DroidModderX

Super Moderator
Staff member
Premium Member
Joined
Oct 6, 2011
Messages
5,782
Reaction score
2,134

The new SafteyNet API released by Google allows apps to check for "device compatibility". In other words if your device is rooted the check will always return "false" and the app would disable some of the features or may not work at all. One of the big apps that won't work if you are rooted is Samsung Pay and Android Pay. Last week we took a look at the "Root Cloak" app which hides root, but there is now an xposed framework module that can do the same thing.

If you are rooted and have Xposed installed on your device you may find that grabbing this module is much more efficient and easy. The xposed module changes the device compatibility check. After applying the module the check will always come back as "true". The app you are trying to use thinks your phone is not rooted and runs like normal. Grab the module from the link below.

via repo.xposed
 
With that module installed I'm still getting an error for Android software and device capability.
Maybe it needs to be extended to return a generic Android build version and a valid device.
Right now if you are running a stock rom variant it's not working. Running Jasmin 8.0 on an LG G3.
I'm running a custom kernel so maybe I'll go back to a stock kernel and see.
 
just installed, thanks for posting.
 
Installing. Will report back.
 
Doesn't work.

I'm getting out of compliance for my work email.
 
Doesn't work.

I'm getting out of compliance for my work email.
87171f20e789f49f15cb59bd5dbe792a.jpg


That seems to be the only way to hide root.
 
Rootcloak works for me. I disabled it and now all my corp emails were deleted.
 
root cloak failed to work for me with hbo now, unless I am doing something wrong.
 
ok credit to Snarksneeze on XDa

I've got HBO Now working on my rooted Note 3(AT&T).

First, I installed HBO Now and tried to watch a movie, which failed with the "rooted device" message. That lead me here, which got me worried.

Second, I installed Root Cloak via Xposed, went into Settings - General - Application Manager and cleared the data to HBO Now, rebooted. Tried to watch another movie which failed.

Finally, I installed Hide My Root and chose "Hide su binary", stopped HBO Now and cleared the data again. To test, I tried to navigate to / via Root Explorer which told me I wasn't rooted. I loaded HBO Now back up and was able to start watching a movie right away.

I'm guessing there are different root methods that can or cannot be hidden. If this didn't work I had planned to use a dual boot to install a non-rooted stock ROM, since my kernel itself is rooted (i.e. I didn't root via app).

[Q] HBO Now fails with rooted devices - Post #3 - XDA Forums

^ that worked
 
Back
Top