New X Owner

VOATMJ1

New Member
Joined
Nov 17, 2009
Messages
22
Reaction score
4
(I posted this on the Tech site, but thought I would try here as well)

I am an original D1 owner, (love it, zero problems) and have upgraded to the DroidX three days ago brand new out of the box from Verizon. I have been experiencing issues with "Flash" not working. On flash content, it loads to 90% and then freezes. I have uninstalled and reinstalled flash to no avail.

I also have issues with the bottom keys not lighting up, the menu, home, go back keys. Sometimes it lights, mostly it does not light up. The phone aslo locks up and drags, and I am getting a lot of forced closes, to include the Androd OS system. Should I take this phone back and get another one or is this the norm for the X? Thanks!
 

jsw6380a

Member
Joined
Dec 10, 2010
Messages
423
Reaction score
0
No that is not normal. I would take that thing right back to where you got it and let them know what is going on. It sounds bone stock without mods so yea, I would take it back. It shouldn't be that laggy out of the box. :icon_ banana:
 

hookbill

Premium Member
Premium Member
Joined
Nov 30, 2009
Messages
19,374
Reaction score
8
Location
N.E. Ohio
(I posted this on the Tech site, but thought I would try here as well)

I am an original D1 owner, (love it, zero problems) and have upgraded to the DroidX three days ago brand new out of the box from Verizon. I have been experiencing issues with "Flash" not working. On flash content, it loads to 90% and then freezes. I have uninstalled and reinstalled flash to no avail.

I also have issues with the bottom keys not lighting up, the menu, home, go back keys. Sometimes it lights, mostly it does not light up. The phone aslo locks up and drags, and I am getting a lot of forced closes, to include the Androd OS system. Should I take this phone back and get another one or is this the norm for the X? Thanks!

I'd try a factory data reset first and if that didn't fix it then I'd take it back. Many of the problems you're talking about sound like an app issue to me so that's where I would start. No task killers or antivirus upon restore. If that fails then take it back.
 
OP
V

VOATMJ1

New Member
Joined
Nov 17, 2009
Messages
22
Reaction score
4
Thanks for the replies, I did a factory reset with a Verizon tech over the phone, and it is still acting strange, and the botton keys still do not light up 98% of the time and flash is still a no go. However when it is acting right, it is really fast and I am impressed with the speed. It's possible I got a bad one out of the box, so I think I will swap it for another new one since it has only been three days.
 

jsw6380a

Member
Joined
Dec 10, 2010
Messages
423
Reaction score
0
Do that, they shouldn't give you a problem. :icon_ banana:
 

The X!

New Member
Joined
Dec 24, 2010
Messages
18
Reaction score
0
Location
California | New York City
Yes...I purchased my X from Dell for 79.99 (just fyi) and I got it yesterday and it's FAST! Wow! On the data side, I don't even know why anyone would need 4G!!! 3G is very fast!!!

So yes...it's your item and not a normal issue.
 

en28so

Member
Joined
Aug 23, 2010
Messages
483
Reaction score
1
Location
San Antonio TX
Sorry to hear you are having problems. My X has none of those issues. Mine is only one week old.

Sent from my DROIDX using DroidForums App
 
OP
V

VOATMJ1

New Member
Joined
Nov 17, 2009
Messages
22
Reaction score
4
Just swapped out the old X for a brand new one at the Verizon store, and this one is rock solid!! dancedroid
 
Top