Need Help Rooting, Kind've stuck


New Member
Mar 24, 2011
Reaction score
I decided to attempt rooting my phone after carefully reading up on it.. I am doing the manual root and am using the guide through Nat3mil on youtube, and Android Police's writeup. [Exclusive] How To Root The HTC ThunderBolt And Unlock Its Bootloader | Android News, Reviews, Apps, Games, Phones, Tablets, Tips, Mods, Videos, Tutorials - Android Police

I downloaded all of the necessary files, and i made sure adb was installed and working.. I was able to make it all the way to step 4 where you put the command to run "adb reboot bootloader" and when i ran it, it said there is no img, or wrong image...

After further investigating, it seems as thought stupid Windows hid the file extension and i renamed the downgrade RUU to The problem is I already ran the adb reboot bootloader command and now its not identifying the device (my thunderbolt) when hooked up to the usb.. How can I remedy this?
If I factory reset my phone, will it at least bring me back to stock, or am I opening up a can of worms?
You should be able to pull the battery, restart the phone and redo the entire process (correctly). And pay attention so you dont end up with a brick.
Okay, this isn't the end of the world. At least you know what you did. First, did you watch the videos linked from the android police post? if not, do it. Namely the adb setup one and steps 2-9.

Just boot back into android. Fix the file on your sd card. From your command prompt run "adb devices". If it shows your device as connected you can run your bootloader command. If not (i think it says offline), simply go into settings, applications, development, and uncheck usb debugging, back out with the back button, then go back in and enable usb debugging again. Run adb devices again and see if your good.

You don't need to access your bootloader from adb though, that's just a shortcut because you're already in adb. You can just power off your phone, and hold volume down while you power up your phone. This will take you into hboot where you can access the bootloader the same way.

Just make sure every time you reboot your phone, before trying to push any commands via adb, run adb devices and see if you're connected. If not, just uncheck usb debugging and recheck it. Then try it again I think I had to do that 3 times in a row to get it to see it once during the process.

Good luck...
Whew, thanks cpjr.. Not sure why I was so afraid just to unplug and pull the battery, but I appreciate your help.. i will finish this later lol
Thanks sgtguthrie. I realized my mistake, albeit too late. After I tried to reboot the with the zip named incorrectly, the computer wouldn't recognize my tbolt so that I could fix the file name.