Mounted "Read Only???"


Mar 11, 2010
Reaction score
OK, so I got my shiny new TB and was ready to make use if all that storage and out some music on my SD card. I wired my TB, selected "mount as hard drive" in the USB menu, and copied ONE music folder to my SD card as a test. Unmounted and tried to play said music... Music played, but ever since then I have an icon in my status bar that reads "Mounted ReadOnly" and now my Gallery won't work and none of my file managers recognize my SD card. Nothing I try fixes this. Any suggestions???
Actually yes... I reformatted my SD card using my PC and a microSD adapter, and then reinserted it into my TB and rebooted. When I atemted to put music on my SD card again, I made a new folder called "Music" inside my media folder instead of putting it on the root of my SD card (my fatal mistake last time, I think) I transferred all of my music files into this new folder and its worked perfectly! Good luck!
Yea, I had the same exact problem, I created a "Music" folder in the root of the SD. Unfortunately I reformatted my sd card before I backed anything up to my computer though.