Issues transferring music from laptop via USB


New Member
Mar 19, 2011
Reaction score
<---First time poster, long time reader

So I picked up my awesome new Thunderbolt on Thursday and love it overall. Yesterday I decided to throw some music onto the SD card. I connected via the included USB cable, selected "Disk drive" on my Tbolt, and copied a bunch of stuff into the media\audio directory. Then I disconnected, checked to see if it worked, and all was well.

I then reconnected to transfer the rest of my music library. Everything looked like it went well, but when I went to check on my Tbolt it became apparent that only two songs had transferred.

Now it seems I cannot transfer any music onto the SD card. Also, I tried deleting all of the music I put on yesterday, but after I disconnect all of it is still there. This is really strange, and it looks like everything is going fine on my PC (running Windows XP). Reconnecting to my PC confirms that nothing was deleted.

1) Transferred some music via USB, everything's cool
2) Go to transfer the rest of my music, everything looks good on my comp but none of it shows in the Tbolt (stuff from first transfer is still there)
3) Plug it back in to check it out on Windows Explorer, none of the new stuff is there now
4) Deleted all my mp3s (still working through Explorer), eject/disconnect, Tbolt is still able to play everything, reconnect, confirms that nothing was deleted

Any ideas? Would it be wise to format the SD card? I really don't want to install that Vcast crap that pops up every time I connect the phone to my laptop.

Edit: I downloaded Astro file manager from the market and deleted/moved around the mp3s on my sd card. When I plug the phone into my computer and look around with explorer the files are still there as if nothing happened. It's like the SD card is read only or something and can't be written/edited.
Last edited: