Lost root after JB OTA update...how do I regain root?


Oct 4, 2010
Reaction score
I hadn't been on the forums in quite some time and didn't know JB was going to drop. I had my phone rooted on ICS and did not temporarily un-root when my phone updated to my surprise. I tried running Matt's XT912 Utility to gain root, but it's not working. Not sure what steps need to be taken. Any help is GREATLY appreciated!!
Any ideas? I found this post and gave it a try:

Edit by Foxcat: Smart Actions in the updated version will NOT work with the Razr_Blade exploit. If you've already updated Smart Actions and haven't yet rooted, you'll need to fastboot back to stock earlier version of Smart Actions using Matt L. Groff's http://www.droidforums.net/forum/droid-razr-hacks/239539-droid-razr-utility-xt912-jellybean-windows-mac-linux-all-one-4.html, and choose option 2 (which will not wipe the phone's data).
This will replace the existing OS with the earlier Smart Actions. Once completed, run the option 3, to root, and then (if you so choose), option 4 to install Safestrap.

But when I try option 2 from AP Fastboot mode, it does absolutely nothing. I've still got Superuser and all my other apps on my phone from when it was rooted before, but SU shows that it's not rooted. I'm hoping my only option doesn't require the words "wipe everything" because I hate to lose everything. I also tried to reboot into recovery and it wouldn't let me. Just gave me a screen with what looked like a dead Droid laying on his back with his stomach open.:angry:
And call me an idiot...even after reading over and over agian, I didn't extract the files into a seperate folder on the desk top. thought I did, but did not. Problem solved. Once I placed all the files from the utility into a seperate folder and ran the tool, I'm now rooted. And all I had to do was option 3. When I got to the step about Smart actions, the battery saver was already turned on. I just switched it off and back on again and went to the home screen. Everything seems to have worked fine. I just did a fast reboot with an app I have that requires root and it worked. Now, off to the tethering hack...