Solved Kitkat micro sd card problem

Naviblue

New Member
Joined
Sep 10, 2010
Messages
4
Reaction score
0
Okay, so I've been trying to fix this for a week now without any progress and it's driving me insane. It has to deal with my ext micro sd card, I can delete a file, multiple files even but when I restart, they all come back. List of things I've tried:

1. Different types of SDCard "fixers" off the play store including modules for Xposed framework. Nothing.

2. Taking the micro SD card out and putting it in an adapter (3 different ones) to reformat = windows cannot do it

3. Playing around with commands both on the phone and on windows cmd

None of the above has worked, anybody know a fix so I can have full control of my micro sd card again?
 
I've had this card for awhile now and it worked just fine prior to kit kat, now, it just doesn't want to keep deleted files deleted.
 
Looks like I've finally found my answer which isn't the greatest one of course...so the answer is the card is toast. When a Sandisk micro sd finds a fault within itself, it goes into a forever write protected mode, not allowing for anything else to be done from it but read...thanks for attempting to help though.
 
Quick update, SanDisk gladly RMA'd my card. The funny thing is, this was the first ever micro SD to go bad on me for years. I think that the whole Kit Kat thing is partially to blame.
 
Back
Top