Infrastructure mode for wireless tether


Mar 5, 2010
Reaction score
Has any one figured out if it is possible to set up wireless tether as an access point (infrastructure mode) instead of ad-hoc (peer to peer)?
The reason I am asking is because many devices will not connect to an ad-hoc connection. It works on the 2.2 Nexus One this way already but different hardware may come into play also.
I have tried the newest version of Wireless Tether which is supposed to support it but still no luck.

Thank you for any input.


New Member
Aug 4, 2011
Reaction score
Probably not happening

I too have had this same issue.

I wanted to tether my $99 HP Touchpad with my first gen motorola droid.... sadly the touchpad wont recognize adhoc networks

I tried the newest build of wireless tether like you guys did... still nothing.

The problem is the chipset.

To use infrastructure mode in wifi tethering you must have a device with a Broadcom BCM4329 or greater.

My next challenge might be to install preware on my Touchpad as ive read that there is a fix to this adhoc issue... not too sure how in depth id like to get with homebrewing my WebOS device since Cyanogenmod 7 will soon be available to flash onto my HP Touchpad device!

I cannot wait till ive got android running on there... its gonna be sick!