ICS bootloader issue

viskar

New Member
Joined
Nov 16, 2012
Messages
3
Reaction score
0
Howdy,

I got myself a Razr not too long ago and right off got ICS 4.0.4 running on it (Wasn't too pleased with the GB).
Lately the phone was getting quite slow so I tried factory resetting it to wipe it clean.
Right after that I found out that I forgot to back some pretty important stuff up and tried restoring a nandroid backup which I created last week.
Some issues with the restoration lead me to follow my friend's advice and re-flash the phone with the files I used to update it using RSDLite 5.6.
I meant to flash SPDIRD-40_ASIA_OPT_1C.91P_CFC_P2B_Signed.xml but instead I flashed SPDIRD-40_IL_OPT_1C.91P_CFC_P2B_Signed.xml which was in the same directory.

I don't know if that cause the issue but ever since then whenever I turn on my phone it goes straight to the AP Bootloader and any attempt to flash it ends in a "failed flashing process 6/22 flash cdt.bin "cdt.bin" -> Phone returned fail" and nothing I do (tried to flash different files or using recovery to flash "Blur_Version.65.1.40.XT910.PSHAsiaRetail.en.03" works - and no, I don't know exactly what I'm doing to be honest)

The phone works though. It seems to power up normally if I press the power button on the AP Bootloader and then kick it into recovery mode and pick power up normally.

I don't turn it off to often so it's merely an inconvenience (as for now) but I'm desperately trying to fix this mainly because I don't want to brick it all the way.

The phone is a retailed sim-free if it's any help.
 
Last edited:

jpcalhoun

Senior Member
Joined
Dec 14, 2010
Messages
1,569
Reaction score
61
Location
PA
Howdy,

I got myself a Razr not too long ago and right off got ICS 4.0.4 running on it (Wasn't too pleased with the GB).
Lately the phone was getting quite slow so I tried factory resetting it to wipe it clean.
Right after that I found out that I forgot to back some pretty important stuff up and tried restoring a nandroid backup which I created last week.
Some issues with the restoration lead me to follow my friend's advice and re-flash the phone with the files I used to update it using RSDLite 5.6.
I meant to flash SPDIRD-40_ASIA_OPT_1C.91P_CFC_P2B_Signed.xml but instead I flashed SPDIRD-40_IL_OPT_1C.91P_CFC_P2B_Signed.xml which was in the same directory.

I don't know if that cause the issue but ever since then whenever I turn on my phone it goes straight to the AP Bootloader and any attempt to flash it ends in a "failed flashing process 6/22 flash cdt.bin "cdt.bin" -> Phone returned fail" and nothing I do (tried to flash different files or using recovery to flash "Blur_Version.65.1.40.XT910.PSHAsiaRetail.en.03" works - and no, I don't know exactly what I'm doing to be honest)

The phone works though. It seems to power up normally if I press the power button on the AP Bootloader and then kick it into recovery mode and pick power up normally.

I don't turn it off to often so it's merely an inconvenience (as for now) but I'm desperately trying to fix this mainly because I don't want to brick it all the way.

The phone is a retailed sim-free if it's any help.
Not not quite sure what you've done, but one problem is if you're flashing an XT910 file to a XT912 phone you're going to have problems. Do you have the CDMA or the GSM version Razr Maxx? To clarify, is your carrier Verizon and do you live in the US.
 
OP
V

viskar

New Member
Joined
Nov 16, 2012
Messages
3
Reaction score
0
Not not quite sure what you've done, but one problem is if you're flashing an XT910 file to a XT912 phone you're going to have problems. Do you have the CDMA or the GSM version Razr Maxx? To clarify, is your carrier Verizon and do you live in the US.

It's a XT910, bought sim-free from a retailer outside the US (middle east).
I've also flashed these before when I upgraded from 2.3.6 to 4.0.4 with no problems whatsoever.
 

jpcalhoun

Senior Member
Joined
Dec 14, 2010
Messages
1,569
Reaction score
61
Location
PA
It's a XT910, bought sim-free from a retailer outside the US (middle east).
I've also flashed these before when I upgraded from 2.3.6 to 4.0.4 with no problems whatsoever.

You have the GSM version of the Razr. The file you're trying to flash is designed and signed for the CDMA version. You may have been successful in the past with some files (I'm surprised) but I strongly recommend using the files designed for your phone. I'm not aware of a GSM sub forum here, but Droidrzr.com has a sub forum for the GSM Razr...suggest you try them if someone isn't able to assist you here...good luck.

Sent from my DROID RAZR using Tapatalk 2
 
OP
V

viskar

New Member
Joined
Nov 16, 2012
Messages
3
Reaction score
0
Thank you for your help.

You're right - There are no carriers using CDMA here so it has to be GSM, but, I downloaded all the .xml's from Droid-Developers SBF and I highly doubt you could find CDMA's designated for my region but I'll take your word for it.

Tried wiping cache and full factory reset from recovery screen and no change.
It's the same problem as in this thread only that I can boot through the recovery menu.

Update:
Gonna give this a try. Will post results for later generations.

SOLVED!
flashing the empty radio .img from the link above worked, phone boots up just fine and dandy.
 
Last edited:
Top