I could use some help. Should I upgrade to Liberty 3? I don't know what I am doing


Jun 1, 2011
Reaction score
In my Liberty pro toolbox I noticed in my Rom List the option for Liberty 3. Generally speaking, if I have been happy with the original Liberty, will I like Liberty 3 more? I am sort of interested in downloading Liberty 3 but am nervous because I am not sure exactly what I am doing.

In my toolbox, I moved ahead a few screens just checking this out. I am really ignorant to what I am doing at this point. It appears I have 3 options. Liberty 3 v 2.0, Liberty 3 v 1.0 and Liberty 3 RC 1.1? I assume I am on Gingerbread but don't know for sure?

I dowloaded Liberty 3, then wiped the cache and data. The phone seemed to finish it's loading when it appears the phone was rebooting, a few seconds later the word "Liberty" appears for a few seconds and my screen goes back to a blank black screen. My phone is stuck repeating this process.

What do I do?
Did you ever check to see what system version you were on? To install liberty 3 you should of been on gingerbread version 4.5.602 or 4.5.605. You may need to sbf now but first you can try to pull your battery and put it back in then press your home button and hold it in then press your power button and hold both buttons in till you see a triangle on the screen. Next press in both volume buttons at the same time and that will get you in stock recovery. Once in recovery use your volume buttons to scroll and power button to select and wipe data and cache partition then select reboot system. Those directions are if you are on gingerbread. If you were on froyo instead of pressing both volume buttons to get in recovery press your search button then use your camera button to select instead of your power button.

Sent from my DROIDX using DroidForums
I can't remember what system I was running but I suspect my problem is I am running on froyo because it was this method which got me in recovery. I wipe cache partition and wipe data/factory reset. Next I scrolled up to reboot system.

Something I noticed toward the bottom, below the little green android guy it says, E:Can't open /cache/recovery/command

After reboot, the same problem seems to persist. The phone seems to start to turn on, I get the word "LIBERTY" that pops up and disappears. This process just repeats itself over and over.

What do I do?
If what i posted above doesn't work just do the 4.5.602 sbf. Then directly after the sbf wipe data and cache partition in stock recovery. Then you'll need to root your phone again and to do that you can use the d3 one click root or zergrush either one will work. In this link you'll find the 1kds bootable 602iso sbf and what you need to root. There's video instructions also http://www.droidxforums.com/forum/g...g/35634-gb-602-root-start-here-links-all.html

Sent from my DROIDX using DroidForums
I just noticed your post above mine so yes you were on froyo so you'll have to sbf and root again. After that you can install Liberty 3 without any problems. You'll be on gingerbread so it's recommend using droid2 bootstrap instead of droidx bootstrap to get in clockwork recovery. Droid 2 bootstrap is just an updated version of DX bootstrap. You can use droidx bootstrap on gingerbread but you'll need to go in your settings > applications > development and make sure usb debugging is unchecked before using it on gingerbread.

Sent from my DROIDX using DroidForums
How do I sbf?

I googled it. The problem is my computer is so old it doesn't recognize my phone. I can't connect my phone to my computer. Do I have to connect to my home computer?
Last edited:

Sent from my DROIDX using DroidForums
Last edited:
Make sure your phone is in bootloader mode before plugging it into your pc. To get in bootloader mode just pull the battery and put back in then hold the camera button first then hold the volume down button and last hold down the power button. Continue to hold down all 3 buttons till you see a flash on your screen then release your power button followed by your other buttons. Now you should be in bootloader mode. All this is in the video i gave you a link to.

Sent from my DROIDX using DroidForums
Thank you for all help Savagerun. The Driver problems have been going on for a long time. I have used that link multiple times and can't seem to fix it. When I am less frustrated I may create a new thread in a different area to see if I can fix the motorola driver issue.

Because of several factors, I switched phones. My father gave me his Droid X he is no longer using. I gave it a factory reset to start all over and I am now up and running. Only thing is I am unrooted and obviously not using a custom rom.

Do you have a link to a thread which can easily walk me through how to root again. I can't remember how I did it the first time. I am undecided on what I will do from there. I am not sure if I will install a custom rom or not. I really liked Liberty and might consider it.

The new Droid X I just got I want to double check on a few things.

The Android version is 2.3.3. Is that Gingerbread?

System Version is 4.5.605.mb810 verizon.en.us. What is this? I don't know what it means?

Thanks again for your time.

Edit:... I was looking at this thread for instructions on how to root. http://www.droidxforums.com/forum/droid-x-rs-approved-guides/41454-guide-how-root-your-phone-zergrush.html

an I root without the need of a PC. I didn't need one last time. I am confused why the process seems more complicated.
Last edited:
Your on the latest version of gingerbread. You can use zergrush to root your phone now. You rooted your phone without a pc last time because you were on froyo and to root froyo all you needed was the Z4root app. But with gingerbread you need a pc.

Sent from my DROIDX using DroidForums
Thanks again Savagerun. I understand things better now. I don't know why my desktop doesn't see my phone? I have tried to use that Motorola driver link you gave me and still nothing. My desktop is really old, maybe 11 or 12 years old? My laptop is only a few years old and I thought I had tried this link with it before and it didn't work, but it worked this time. So as far as I am concerned that issue is solved. At least I have a connection to a PC.

Only issue or question I have is when I bought my original droid X back in about September of 2009 and after several months I rooted it and shortly after that I downloaded Liberty on it. This is when my desktop stopped communicating with my phone. Is this a coincidence? I can't remember if it stopped after I rooted or the Liberty rom installation but is there any reason why this is a correlation or just coincidence. All I know is my first bought Droid x worked fine on my laptop (it never did on my desktop, some tech support person told me something about windows xp ins't communicating with the new phones well and windows 7 does and that why my laptop sees it??)

At this point I don't care. However I am interesting in rooting my phone I got from my dad and I hope there is not the issue it stops responding to my laptop.

Anyways, thanks again Savagerun. I really appreciate your patience and help. Forums and people like you who are willing to help are what make Android a better experience than IOS.

Im not sure what the deal is with your desktop not recognizing your phone especially if it did in the past. I can tell you it has nothing to do with your phone being rooted. I personally never had that issue but i have heard of people that have had issues using a different usb cable other than the original motorola one that came with the phone. I've only used the original cable every time i need to connect to my desktop or laptop and never had a problem but then again my equipment is fairly new.

Sent from my DROIDX using DroidForums
Someone told me it's because my desktop is windows xp and my laptop is windows 7. I find that hard to believe, as long as one works I don't care.

Last thing I want to check on. I don't know exactly what was on my sd card on my old droid x, like pictures for example. Do I have to do something special to move the sd card from my old droid x to my new one? Can I just physically remove it from one phone and plug into my newer droid x? Is it that simple? I have not checked but I don't remember if I have some pics that have some sentimental value to me were also uploaded to my picassa account.

Now that my laptop can communicate with my Droid X, I can flash it and get it back up and working. Will I loose the pics when I do this? I am not sure where videos and pics were stored, if they are on the sd card and if that is recoverable or not?