I am at my wits end, PLEASE someone help me out. Repeating error message


New Member
Jul 19, 2011
Reaction score
I seriously am about to just go insane. Ya know that movie, "Falling Down" with Michael Douglas, where he finally just looses it during a traffic jam? I think I'm right about at that point with this.

I have W7, 64bit using a LG Revolution android phone. So far I have used two different USB cables and three USB ports. I tried several different modes from charge only, to modem mode. Nothing has seemed to work. What happens is this...

I plug my phone in via USB cable on my PC to charge. Every damn minute to three minutes that annoying ass little window pops up by my time clock and says that the USB Device is not recognized. I tried going into the settings for that to stop alerting me but it just auto-resets itself to alerting me, every damn time. Now my phone actually works in modem mode. I can transfer files easily. There is no problem with the function, just that my computer keeps telling me it's an unrecognized USB device over, and over, and over, and over again.

I am going to loose my mind if I hear that stupid "duh-dun" noise with that error message one more time. Please, someone, anyone... is there anything I can to make my PC recognize my damn phone, or at the least get the message to stop popping up every few seconds??
Have you gone to LG's website to see if there is some sort of driver available?
I did go to their site, but I didn't find any place for drivers. I'm gonna just try a google search for them though. We'll see if this will work. Stay tuned.

EDIT: Ok so I found where the drivers are on their page. I downloaded what I thought was the correct one from here under the VZW section. It has yet to do anything :-/ The "USB Device not Recognized" error popped up several times while it was installing and when it said completed, just to troll me, popped up again. :-/
Documents for your LG Phone

Requires Acrobat Reader


you installed the drivers and still getting an error.
you installed the drivers and still getting an error.

That is correct. Both yours, and a different one from the link I posted in my first response post. What's the most disconcerting (and ANNOYING) is not that I am getting the USB not recognized error, but the frequency that it keeps popping up. It's as if the phone keeps looping through trying to establish some connection with the computer, and the PC isn't recognizing that connection.
Can you try it with another computer in the house.
when you connect to the pc to charge do you put it in transfer mode or just charge mode?
unfortunately I can't. I live by myself and only have my one PC. But I can try this tomorrow when I to work. Let's assume I plug my phone in via USB at work and all is fine. No repeating error message. So then we know the trouble is with my phone and my PC specifically. What suggestions would you give me in this situation?
Well i'm just thinking that while in charge mode the PC doesn't know what the phone is doing for some reason, but in transfer mode, it just considers it a sdcard. So I'm not sure where the problem lies.

For sure check it on another PC to see if it suffers the same way.
Will do. I'll report back tomorrow at work with what happens. Thanks everyone so far.
Ok guys, so I just got back from work. Here's what happened...

... I took a fresh, new USB out of it's bag, plugged it into our unlocked work PC and then plugged in my phone. The exact same issues occurs where the pop window by the time clock appears stating my USB Storage device is no recognized. It goes away, and several seconds later it pops back up.

I've tried to find a pattern with the time it takes before it pops up again, and to no avail, there isn't one. It cold 3 seconds after it went away, it can get close to a minute other times.

So, at least I know it's not my computer, but instead though... looks like it might be the phone then, would you say?