Droid 4 by Motorla - USB connection not working

Ragemaster9999

New Member
Joined
May 30, 2012
Messages
1
Reaction score
0
Hello, I have a Droid 4 by Motorla (verizon) and I having major issues getting the phone to connect to my computer by USB cable. I am running Windows 7 64 bit, on both my laptop and my desktop, and I keep getting the following error messages when connecting the phone to either of my computers... one of the usb devices attached to this computer have malfuctioned or stopped working, windows was unable to recognize this device. I have tried multiple usb ports on different computers, tried different usb cables, and still have the problem every time. I even downloaded the USB driverr management tool from Motorola and it still does not work.

Any suggestions, im about ready to take the phone back to Verizon and complain because I don't know what else the problem could be, other than the phone itself?

edit: forgot to add, even though it cant recognize my phone, the device still charges when connected to the computer.
 
Last edited:
Same exact problem. Droid 4, Win 7, 64. Charges but does not recognize the connected usb device. Please advise.
 
Back
Top