Help Restoring Root and Bootstrap after .906 update


New Member
Jul 8, 2011
Reaction score
Hi Everyone,
I got the message this morning that the .906 update was available and pushed it through. For some reason I thought since I had bootstrap, it would prevent me from having to reroot and all that jazz after any update. But it seems I have lost root and I don't have the prompt before the splash screen indicating I have bootstrap.

Does anyone know the best/safest way to restore both after previously having them setup?

Thanks in advance.
You can use the motofail method to restore root. Took 5 click...and worked like a charm. I think if you google you'll find the zip file...Just unzip and run the batch file with phone connected via usb. There's also a link on this board I believe.

Are you talking about tweaked bootstrap, or safestrap? I had tweaked bootstrap and it was still there after the new version downloaded.
I believe you must be in "charge only" USB mode also...
Where is that "charge only" mode setting? I can never find it in the settings menu
Everything is up and running again. I ran motofail and got root back. Then I remembered I had the safestrap app and ran that, and now safestrap is back. I never had bootstrap but this was easy enough if I need to do it again in the future.

Fishacura: The "charge only" mode comes up when you plug your phone via USB and then select the notification option that comes up.

Happy to be back on root and now at .906 Camera already seems a little snappier.