HELP! nub. cant log in with droid x forum app.


New Member
Jan 12, 2011
Reaction score
Hello all. Im totaly ignorant with the android. I spent the last three years with the iphone. So I have A LOT of questions. So please bear with me. Lol. The problem at hand is that I just registered for this forum but had the app for a few weeks now. I can log on via internet but it wont let me log on on the droid x forum app. When I try loggin on on the app it says " u have entered an invalid username/ password or ur administrator has restricted access via tapatalk." Iv been fighting this for about 15 minutes. Making absolutely sure that im typing everythin in correctly. And still it wont let me.... any suggestions???????
Try uninstalling first.

Sent from my Droid using DroidForums App
Nevermind on how to uninstal. Lol. I figured it out. Ill reinstal and see what I can come up with. Thanks dude.
Three things.

One, try changing your password to something insanely simple, like 1234567890, logging in via the app, then changing it again to whatever you want, then logging back in to the app once you've verified you don't have any problems.

Two, have you tried clearing the data and the cache from the app in the app manager?

Three, Are you trying to log into the app with a Droid X Forum login?
restricted via tapatalk

Th0mas, did you figure it out? I'm having the same problem and none of the suggestions have worked.
If you're trying to log into you need the droidforums app, not the DroidXforums app.

Sent from somewhere...