Help! My screen wont go past the M screen.

depdaDROID

Member
Joined
Nov 12, 2009
Messages
55
Reaction score
0
Last night I was trying to install BBv.4 on my Droid from RM. I had trouble flashing cm recovery (in fact the RM gave me a msg: CMRec. broke and for me to email koush with the bug). I then tried sp recovery and back to cm recovery and it worked ok. I downloaded the BB rom and the first time I selected back up existing rom and wipe data cache but it only rebooted back to the jrummy froyo v.1 that I was currently running at the time. I tried again and it went into cm recovery and installed BBv.4 ok. I noticed the rom was very buggy and decided to do a nandroid restore to one of my previous backups. Apparently during the restore or reboot the battery drained. Now it will not reboot into recovery (on wall charger) and only displays the M logo.
What can I do? I have RSD lite on my PC, can I flash another recovery??
 
Charge the thing for more then a few hours, then retry. This is not a new issue, you will have to be patient and alow the batt to charge.
 
I tried charging it for hours...I even brought it to verizon and they switched batteries and had it on their charger and no good. The screen still only shows the M logo and dosen't reboot. should I try and flash a recovery with RSD lite? How is that done given my situation? Thank you for responding with your suggestion.
 
You tried to have Verizon fix your rooted droid? Thats classic...

I don't know all the details, but can't you just boot into SP Recovery with PWR+X and flash a nandroid recovery to make it all good again?
 
Back
Top