Google Calendar Syncing Issues


New Member
Aug 17, 2011
Reaction score
I'm on pre-Rooted GB. There are many events on my Google Calendar that don't show up in my phones Google calendar. I have already verified Google sync settings, calendar visibility, clearing calendar app cache. Anyone know how to fix this? The month of August is synced correctly, the problem seems to be July and months previous. Months before March don't show any events on my phone, although there are in my Google Calendar.
Verizon did it!!

Verizon has added their own calendar to their Droid X2.

Open your calendar; click on the left button at the bottom of the Droid; Settings; Manage calendars

There you will see your gmail address and your main google calendar and all your google sub-calendars.

Each one will have a double icon to the right: SYNC & HIDE You can click on each to control this.

Then go to the bottom of this list of calendars and there will be a break and "Phone Calendar".
This is the calendar that VERIZON has added to their Droids. When you enter any event in your Droid will go into that calendar!!!

And now look at the double icon on the side = Verizon has grayed out the SYNC ICON!!

gee thanks Verizon.:icon_evil:
I called Verizon tech support and she had me dial *228; when the message starts, select 1; the phone will be reprogrammed; when it's done, click NEXT

It will go back to the main screen and it will reset itself. That did nothing to cause the Phone Calendar to now sync.

They moved me up the tech ladder. :icon_eek: And we figured out how to get around the Verizon Phone Calendar:

1. On your Droid desktop: Click on your calendar icon
2. At the top, you will see a drop down menu for all calendars. If you have unselected any, it will show the # of calendars you are using - click this
3. scroll down and find "Phone Calendar" - uncheck it
4. click Done and add an event into your calendar
5. click the green +
6. notice at the top, there is a drop down, probably with your name on it. Click it and you'll see any Goggle sub-calendars you have created. Your name is the primary calendar.
7. create your event & save it
8. This may be all you need to do - but we took it a step further and forced a sync:
9. Go back to the Desktop and click on Settings; Accounts; your Gmail account
10. Make sure your Sync Calendar has a green check mark, as well as any other google app you want to sync
11. click on the Droid's Menu button and a bar comes up with "Sync Now" = click
12. You go right back to the list of Google apps - initially it looks like nothing is happening. You should see the sync icon at the very top bar; and you should barely see a grey sync icon to the left of each green checkmark. They disappear when the syncing is finished. (I didn't see any of this and had to go back into Settings and turn on my WiFi).
13. My TEST calendar event popped up into my home PC's Google calendar!! success. dancedroid:icon_ banana:

When ever you have been traveling, use the *228; select 2 = and it will reset for the area cell towers.
Your phone will respond faster if this reset is done each time the phone is in a new area.
I have tried 3 third party calendars, Jorge (?) Calendar Pad Pro (?) and now Business Calendar. On all three I have never had any issues with Google Calendar synching if data was enabled. The first one is free, the second has a free and pro version and the third is a few bucks. Well worth it if you depend on your calendar as I do.