Gmail not sending from droid

Fixed it!

Somehow the autosync was turned off. Here's what I found on another site:
First select your gmail icon, then hit your options button and select accounts. On top should be the envelope with the gmail written next to it underneath should be your gmail account. Next, hit your option key again and seletct account settings. There should be a Background data checked green and underneath is Auto-sync. Make sure that is checked green. Mine wasnt and after highlighting that option, the section beneath labeled "Manage accounts" switched to Sync is ON with a grean circle (refresh symbol) appearing.

This fixed the sending problem for me, as well as not telling me about new emails. Thanks for the help!