Solved Extremely serious boot loop issue


New Member
Jul 29, 2014
Reaction score
Current Phone Model
Motorola Razr i
I own a Motorola RAZR i and have done for a year with no major problems. The phone is not rooted, and is running jelly bean 4.1 I believe. I had not downloaded any new apps when this problem started to occur.

Firstly my phones notification bar and soft keys stopped showing up for a few minutes at a time, then apps kept crashing without any error messages, and now finally on one particular app crash the phone will not turn on. All within the space of a few days.

After endlessly searching forums, I feel this is no normal problem. The phone is stuck on its boot logo (red motorola 'm'). Upon forced restart (hold volume down and power keys at the same time), the phone shuts down and immediately restarts. The only way to get it to turn off it to let the battery drain.

Upon a charge and attempting to get to a recovery menu from power off and turning on via a key combination (every key combination under the sun) it will still only try to turn on normally. It vibrates, then shows the motorola logo.

Essentially, this leaves me unable to turn on my phone, or access a recovery menu.

Is there anything that can be done to fix this issue? I will happily answer any questions as soon as I can, thank you for your time.
I moved this to RAZR Support. Wish I could offer more help. Hopefully someone else will come to your rescue

Tapped from a Moto X
I moved this to RAZR Support. Wish I could offer more help. Hopefully someone else will come to your rescue

Tapped from a Moto X

Thankyou, greatly appreciated!

Problem is still not solved but the phone will now successfully boot into the recovery menu. I'm not sure how this happened but it started soon after I plugged it into a computer it knew, and used its official USB cable to do so.

I factory reset the device and wiped the cache many times and still the device will get stuck on the M logo.

I am now trying to install a fresh firmware/ROM onto the device, but this appears to need USB debugging enabled, which I cant do as the phone will not turn on. I will keep trying, but if anyone knows a way to enable USB debugging without fully turning the phone on (remember I can go to the boot menu) then that would be awesome, thanks!

After not knowing the first thing about android customisation, I have finally fixed the issue after many hours of constant googling! IMPORTANT, lots of this is specific to the Razr i, you need to be sure you are downloading the materials for your specific phone. Lots of these instructions very between phones, but the core procedures should be possible on all phones. If in doubt, google the specific instructions for each action for your phone. Good luck!

I'm not sure which parts are necessary, but I will include most of what I did just in case anyone has a similar issue. BE AWARE, a key part of this solution is 'RSD Lite', a program. I really don't know if it works with phones other than Motorolas, please check beforehand if you can.


I am simply showing a solution that worked for me, I am only trying to help, thus I am not responsible for any failures or damages that occur during this process. If you are a noob like me and don't know much about this kind of thing, I would recommend saving yourself some trouble and returning your phone if you are still under warranty (I was not).

Before you begin: BACK UP your SD card, it is possible you may accidentally wipe it during this process)

1. You need to unlock the boot loader on your device. On this website it provides a link to another site for unlocking the bootloader (Varies between devices, google your sepecific devices instructions). (The rest of the linked site is also very useful) [VERY IMPORTANT: The links to the Root package and ClockworkRecoveryMod are specific to the Razr i, you need to find the specific download files for your device!!!!!]

2. After you have done that, continue following the steps on the webpage linked in the first instruction. The first command prompt command will not work, but you can do this manually on a Razr I by holding down the volume down and power button keys at the same time, when the phone vibrates you need to take your finger off the power key and keep your finger on the volume key without taking it off. Other phones can do this, but the key combinations for doing will probably be different. This will boot it into bootloader mode.

3. The other commands should work as long as you carefully read everything. This installs a custom recovery (ClockworkMod) however I changed this to TWRP by using a different .img file in the second command you are told to execute (I don't think this is absolutely necessary). In instruction 11, ensure you use the correct file name for your .img file. I cant rememebr if the Root package worked or not, but I think it did. Follow instructions up to 19.

4. The bootloader should now be unlocked (it will display a warning on start up) and you should have a custom recovery which can be accessed from the bootloader menu by pressing recovery.

5. At this point I tried using the custom recovery again and again to install a new ROM. Nothing worked, it always failed and I couldn't figure out why. But then on a website I was browsing someone casually mentioned RSD Lite (Download link is in the first post). I cannot thank this person enough. For some reason it wasn't mentioned anywhere else. Get RSD, and now find a stock firmware for your specific phone (Model and carrier). For Motorola devices, this website is very useful. Most other devices have official firmwares on their website or on a downloadable program.

I don't know if RSD works with phones other than Motorola unfortunately.

6. With my custom recovery, I wiped the system and all caches but I don't know if you need to do this or if RSD does it automatically. This left me with no OS installed

7. Follow some tutorials for RSD and remember to put the phone into bootloader mode (use your phones specific key combination, what he does in the video probably won't boot your phone into bootloader) so it can be detected by RSD. Place your firmware in where the tutorial tells you to, and let RSD do its thing.

8. After this my phone worked perfectly. Hopefully yours will too. If anything needs to be cleared up I am happy to help.

In summary, it turns out it is possible to flash a ROM without using USB debugging at all. Phew!