Droid X Ubuntu/partition


New Member
Dec 2, 2010
Reaction score
Hello all.

First off, I didnt want to revive an old thread so I am starting a new one.

I have scoured the web and droidforums.net for about 3 weeks and I still cant figure out what steps I am missing. I am programmer and comfortable with anything computers. although I am fairly new to linux and brand new to android.

Heres what I have done.
Droid X running Chevyno1 SSX
downloaded ubuntu found on another forum.
partitioned 16gb SDcard to have primary as fat32 with 14gb and ext3 with ~1.3gb
put back the files that I had on SDcard into the fat32 partition
followed the steps for installing ubuntu

I have followed everything to a T. I can post the errors if needed, but they are the same as the other posts that people have posted...
# sh ./ubuntu.sh
sh ./ubuntu.sh
modprobe: chdir(/lib/modules): No such file or directory
←[H←[Jrm failed for -f, No such file or directory
rm failed for -f, No such file or directory
rm failed for -f, No such file or directory
rm failed for -f, No such file or directory
rm failed for -f, No such file or directory
mkdir failed for /data/local/mnt, File exists
←[H←[Jrm failed for -/system/bin/mountonly, No such file or directory
Unable to chmod bootubuntu: Operation not permitted
Ubuntu Chroot Bootloader v0.1
Ubuntu Bootloader is now installed!
This process does NOT damage Android OS!

Original Installer by Charan Singh
Modified for Ubuntu Chroot by Max Lee at NexusOneHacks.net

To enter the Debian Linux console just type 'bootubuntu'




mknod: /dev/loop2: File exists
ioctl LOOP_SET_FD failed: Device or resource busy
mount: No such file or directory
mount: No such file or directory
mount: No such file or directory
net.ipv4.ip_forward = 1
Setting /etc/resolv.conf to Google Open DNS and
bootubuntu: cannot create /data/local/mnt/etc/resolv.conf: directory nonexistent

bootubuntu: cannot create /data/local/mnt/etc/resolv.conf: directory nonexistent

Setting localhost on /etc/hosts
bootubuntu: cannot create /data/local/mnt/etc/hosts: directory nonexistent
Brought to you by NexusOneHacks.net and the open source community!

chroot: can't execute '/bin/bash': No such file or directory

Shutting down Ubuntu


My questions are:
1. After I partition and reboot, how can I tell if the ext3 partition gets mounted, or how can I mount it manually? (I have scoured the web too long and couldnt find the right answer.
2. on the install from SSX it says that the ext* is supplied in modules. Does that mean that I have to insmod them? if so where are they?

3. When I run mount i get
# su
# mount
rootfs / rootfs ro,relatime 0 0
tmpfs /dev tmpfs rw,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
/dev/block/mmcblk1p21 /system ext3 rw,relatime,data=ordered 0 0
/dev/block/userdata /data ext3 rw,nosuid,nodev,noatime,nodiratime,errors=continu
e,data=ordered 0 0
/dev/block/cache /cache ext3 rw,nosuid,nodev,noatime,nodiratime,errors=continue,
data=ordered 0 0
tmpfs /tmp tmpfs rw,relatime,size=2048k 0 0
/dev/block/pds /pds ext3 rw,nosuid,nodev,noatime,nodiratime,errors=continue,data
=ordered 0 0
/dev/block/preinstall /preinstall ext3 rw,nosuid,nodev,noatime,nodiratime,errors
=continue,data=ordered 0 0
/sys/kernel/debug /sys/kernel/debug debugfs rw,relatime 0 0
/dev/block/vold/179:1 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,u
=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
/dev/block/vold/179:1 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,relat
arset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
tmpfs /mnt/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=000 0 0
/dev/block/dm-0 /mnt/asec/android.androidVNC-1 vfat ro,dirsync,nosuid,nodev,noex
ortname=mixed,utf8,errors=remount-ro 0 0
/dev/block/dm-1 /mnt/asec/com.wyse.pocketcloudfree-1 vfat ro,dirsync,nosuid,node
9-1,shortname=mixed,utf8,errors=remount-ro 0 0

I see that some things are in ext3, so I would assume that the ext* are currently working. But not exactly sure how to tell what is what.

When I run df I get

/dev: 244372K total, 0K used, 244372K available (block size 4096)
/mnt/asec: 244372K total, 0K used, 244372K available (block size 4096)
/system: 285950K total, 212948K used, 73002K available (block size 1024)
/data: 6918288K total, 396944K used, 6521344K available (block size 4096)
/cache: 188403K total, 8341K used, 180062K available (block size 1024)
/tmp: 2048K total, 4K used, 2044K available (block size 4096)
/pds: 3963K total, 1102K used, 2861K available (block size 1024)
/preinstall: 126931K total, 113165K used, 13766K available (block size 1024)
/mnt/sdcard: 14219600K total, 4952048K used, 9267552K available (block size 8192
/mnt/secure/asec: 14219600K total, 4952048K used, 9267552K available (block size
/mnt/asec/android.androidVNC-1: 2088K total, 140K used, 1948K available (block s
ize 4096)
/mnt/asec/com.wyse.pocketcloudfree-1: 4164K total, 2536K used, 1628K available (
block size 4096)

Here it doesnt look it is reading the ext3 partition.

I am assuming that this is what is holding me up, by it not being able to access the partition ubuntu cant install onto the ext3 partition which it needs.

Any help would be great. I have read and read and read and have not been able to figure it out.

Any help would be greatly appreciated. Thanks
im kinda... well a noob.
but i think for number 1, you can use root explorer or adb/terminal emulator:
su (obviously :p)
busybox mount -o rw,remount -t ext3 /dev/block/system /system

Sorry if im waaay off (i can tell your techsavyness has magnitudes on mine :p)... but this may help in the future:
BusyBox - The Swiss Army Knife of Embedded Linux
I tried something similar before. But just to make sure I did it again.. Same results. Thanks for the reply
Any luck on getting this to work? I was hoping to do the same.

I don't think the nexus one hacks method will work, as the Droid X doesn't have the needed loop file sytem kernel module to mount the ubuntu disk image (IIRC the nexushacks.net method involved mounting a disk image of ubuntu and then chroot into it), however I did see one report of of a user using debbootstrap to install debian onto an sdcard partition and then use chroot, bypassing the need to mount a disk image.

..regarding your problem with mounting your ext3 partition, perhaps this helps:

...to mount the sdcard partition somewhere on the android file system look in /dev/block for the sdcard partition. Typically it will be mmcblk0p# where # is the partition number. Mount as follows:

# mount -t ext3 /dev/block/mmcblk0p2 /data/local/mnt

..remember to replace the /dev/block/mmcblk... string with the correct one for your sd card's ext3 partition, and also change /data/local/mnt to the location you want to mount your ext3 partition to (the directory must exist.. once mounted you should be able to browse that partitions contents inside that directory)

If I have any luck with my trials I'll let you know! ;)
I found a how to for building the needed kernel modules for the Evo; I think I'm going to try and follow it using the Source code for the DX..

How-to (steps 1-13):
How to Build Your Own HTC Evo 4G Android Kernel! | HTC Evo 4G Hacks!

Source Code:

I managed to build the loop.ko (kernel module), as well as a few others (ext2/4, tun, fuse, and cryptoloop)

I just tried loading the loop.ko and I am getting the "Exec format error"...

I found a possible solution, but I'm at work... I'll check on it when I get home:
Last edited:
WOW, so far looking better. Sorry, I have been away for the past week. I will take a look at this later and see what I can come up with as well. It will be a day or two.

Great work, cant wait to get back to this project.

Getting much much closer. I will be back on soon.