DROID X RSS newsfeed and facebook widgets won't update and can't check for OS updates


Jan 2, 2011
Reaction score
Hey there! Sorry if this is redundant, as I've seen different threads complaining about this kind of issue; however, have not been able to find resolution, so I thought I'd start a new thread to see if someone can point me in the right direction.


RSS: Newsfeed widgets won't update. I removed the RSS feed subscription and attempted re-add it. The phone was able to detect that there was an RSS feed on the website (tried multiple), but when I hit "SUBSCRIBE", I get, "Error Try again later."

Facebook: The market facebook app works properly. But trying to get facebook to sync (it was previously synced just fine) is unsuccessful. When I try to add a social network via the Social Networking app or if I go to CONTACTS > SETTINGS > ACCOUNTS > Add account, there are two instances of Facebook listed. Before, one of them (the smaller of the two icons) would have the e-mail address box shaded out, but the password box allowed me to enter a password but with no account e-mail address to marry it to. I was able to successfully remove the account via this thread: http://www.droidforums.net/forum/an...an-t-remove-facebook-account-my-accounts.html using SQ Lite editor (this cured it the last time I had a problem), but now when I try to log in with the "other" Facebook icon (this one seems to be linked to the Social Networking app, the other seems to be linked to the Facebook market app), I get, "Adding Facebook account" for about a half second and then, "Error Your request was denied, please try again." Facebook contacts will not sync with phone contacts (though I have sync checked). (I'll get to "what I've tried" after the symptoms)

Can't update the phone:

I go to System Updates under "About Phone" and get (almost immediately), "Check for update is not available at this time. Try again later."

What I've tried:

I've removed the Facebook market app and used the SQ Lite editor to remove the string as instructed. This changed the small Facebook icon within the Social networking accounts to allow me to enter an e-mail address; however, I get the error mentioned above. It doesn't seem to act like it's a bad email/password...it's like there's no connection attempted. Plus, I can log into the Facebook app. I also tried re-removing/logging out of the larger icon Facebook app within Social Networking and then re-trying to log into the other. Failed. Same messages.

Naturally, I did the battery pull, reboot, cache clean, etc.

I am rooted and use Droid Wall and App Quarantine. I also have Root Browser. I attempted to un-quarantine and restore all blocked apps. I had not blocked anything new between the last update of my widgets and the problem starting. I removed all widgets as well to try to give the phone a clean attempt at restoring this. Had had previously been getting offered the new update for the DROID X but did not download it so as not to lose root.

I also attempted to clear data on the social apps. Some would not allow me the ability to clear the data. I also cleared facebook data before uninstalling the app.

I'm trying to find a solution that doesn't require system restore.

Anyone else seeing this or have an understanding what function shares all of these issues?