Droid Running very Slow, looking for ideas on what to adjust

ohioDroid

Member
Joined
Jan 11, 2010
Messages
308
Reaction score
0
It's kind of tough to figure out. Normally one would just do process of elimination, but I've done so many things I'm not sure what I can eliminate.

It's like the phone crawls (but not all the time!). Sometimes I just click on the icon for an app and it takes 10 seconds to load. Just now I clicked the camera button. The phone did a quick vibrate like normal, but didn't start the app at all. Tried it like 3 more times before it actually did the work.

I thought maybe it's because I'm using App2SD and have some apps on my SD card, but an app like Handcent SMS is on the phone's internal memory and it still occasionally takes forever to open. This is incredibly inconvenient.

Yesterday I went to my call history. I clicked the 'call again' button. The phone sat there for 13 seconds on the same screen, and then I heard it start ringing. And THEN it switched to the phone screen, showing my contact and the call time and stuff.

I am running what was a leaked 'stock' rooted 2.2 FRG22 ROM. I'm using ChevyNo1's kernels, and I've tried various ones, ULV, LV, regular, whatever. Currently on 2.6.32-ulowV-1.25Ghz, they all seem to have the same issues so I'm not sure it's the kernel.

I was running the phone at 550MHz but since it was slow I upped to 800MHz, I haven't noticed a change in speed, though.

Running services include SetCPU, myLock, Skype, Google Messaging, Genie News and Weather, Email Sync Manager and Swype.

Running applications include Android System, Calendar, Clock, Contacts, Dialer, Dialer Storage, Email, Google Services Framework, LauncherPro, myLock Auto Unlock, News and Weather, Set CPU, Settings, Settings Storage, Skype, Swype.

I'm just not sure what to do right now. The math adding up the memory for these apps and services seems to say I should be okay, but then the phone will run slower than a Windows 95 PC and I wonder how many things am I doing wrong to make this happen.
 
i heard of setcpu causing a backlash on the system if not configured properly. i would remove/disable it.

have you tried booting into recovery and clearing the dalvik?
 
Last edited by a moderator:
I used the given link to download the Cache Clearer and run it, and then I booted into Clockwork Recovery and cleared Dalvik.

LauncherPro always takes its time to get going upon boot, but now every app is opening quickly, menus are snappy and the phone is acting like it should again. So this seems to have worked. Thanks a lot!
 
Back
Top