Droid Razr M stuck on boot animation, won't detect on USB


New Member
Dec 26, 2014
Reaction score
Current Phone Model
Motorola Droid Razr M
Hi all. I have a bone-stock Razr M, the only mod is that I've unlocked the radio to accept a T-Mobile SIM. It started having an issue where it starts up, the boot animation starts playing with sound, then a couple seconds in the sound shuts off but the animation continues to the glowy idle portion, and stays there until the phone runs out of battery.

I booted into recovery and did a factory reset, as well as trying to flash original ROMs for Blur_Version.98.30.1.XT907.Verizon.en.US and Blur_Version.77.111.10.XT907.Verizon.en.US. Both erred with a message about fingerprints not matching, could that be because the phone is not rooted?

I also set the phone into fastboot mode and tried to run the Motorola fastboot to flash a recovery image that way, but fastboot doesn't see the device; I tried this on three machines, including a Win7 machine with just USB2 ports, since I heard that USB3 can be an issue.

Unfortunately I don't know what my original ROM version is, and don't know how to query it since I can't get the phone to a screen that displays it.

I suspect that the USB port is not working beyond being able to charge the phone, and thusly I am screwed. I'm guessing my only hope is a start ROM that my phone will accept in recovery mode, however most of the links I found to download these are dead. Any tips before I chuck it?

Thanks in advance!