Clockworkmod not booting into recovery


Sep 5, 2010
Reaction score
EDIT: scratch that. after flashing the recovery about 10 times it finally started booting to it... but now whenever I boot my DX, it goes to CW recovery, where I have to reboot it from there in order to get things running... HELP!

I've got the ROM manager, bootstrap recovery, and clockworkmod recovery installed; DX; rooted 2.1.

I had this on my previous DX with no issues, but for some reason, I can't get my new device to boot into clockworkmod recovery (manually, via bootstrapper, via rom manager)...

any ideas?

about to "return" this app and leave a bad rating :(
Last edited:
ok so im trying to do the same thing you are except i cannot get the recovery to work. Rom manager says its installed and i cant revert, there is no option to erase in settings and i have reinstalled it about 5 times and still not getting anywhere. What did you do to finally get it to boot into recovery?
so you are/have:

rom manager
bootstrap recovery
clockworkmod recovery
busybox (not sure if this is needed here... I can never remember, but I have it)
SU permissions applied

I just kept reflashing the current recovery (it wouldn't let me download older recoveries or install an alternate...) and rebooting using the rom manager and it finally started to boot to the recovery...
I thought we didnt need the bootstrap with the CWM, i could have swore i seen a post about not needing it after a while. I installed bootstrap and now its booting in just fine, Im just uneducated is all. BTW im running the leaked 2.2 rooted, trying to install the FLYX rom.
haha, I can never figure out exactly what's needed... it's rarely clearly stated and it's different in each place you read.
Nah, I've thought about it though. I'm new to all of this and I was kind of wanting to see what the official stock 2.2 looked like first then look at custom roms based off of that. To be honest rooted stock 2.1 has given me all the functionality and UI experience I need...
I cant get mine to boot into recovery either.. i can from the app and bootstrapper but not by home button power button thing.. it boots into normal recovery. any suggestions
nevermind figured it out you have to let it start to boot then do battery pull then it will boot into clockwork recovery..
I've been trying the same thing, however while going down this "checklist" I noticed when I go in to superuser it doesn't list anything for permissions... Also in Rom Manager if I try fix permissions, it comes up with an error...

I installed and ran Bootstrap
then ran rom manager to Flash Clockwork Mod recovery says it completed
but if I try reboot into recovery I click it and nothing happens...

Is it possible my phone isn't rooted, even tho I have SU app??

EDIT: Never mind, turns out I did loose root some how, re-rooted, bootstrapped, flashed Clockwork Recovery, and everything worked fine...
Last edited:
so i have the phone rooted... atleast that is what is says... rom manager, bootstrap, the new room on the root and all set. I open rom manger, chose install rom from SD card, chose both boxes and then reboot.. and nada.... i then try and select Roobot into Recovery.. and nothing. I then try to re-flash recover, and start all over and nothing... any ideas?
When you run bootstrap does a box pop up in the bottom saying the access was granted to bootstrap?? same when you load rom manager, and Flash ClockworkMod Recovery, does a box pop up asking for superuser permission??

If these boxes don't pop up, then open the Superuser app, and see if there is anything listed... if there is nothing listed, then you have the superuser app installed, but lost root access... that was what happen to me, I assume because when I updated to the leaked 2.2 I must not have moved the files that needed to be moved.

If this is the case, the easiest way for me was to sbf back to 2.1, then root, the install bootstrap, rom manager, then from rom manager I just updated to 2.2 from the downloaded roms/stock Images/Verizon Droid X 2.2

then I was back to 2.2 rooted.

EDIT: Also keep in mind that if the phone is NOT properly rooted, neither Bootstrap or Rom Manager will tell you when you flash, it acts like all is well, even tho it isn't... thats what stumped me for so long
So what is the exact process to boot into CW recovery from powered down state.

When does one need to pull the battery?

Arcstriker.. thank you for replying back. My issue is not bumping up to 2.2. I can do that now with my eye closed :)... the issue is once i get 2.2 on there, i open RomManager, download FlyxFinal, select both boxes... but the phone wont reboot. it seems to me that RomManager lost Root during the 2.2 upgrade. I have been reading online that the latest RomManager is a bit flaky. Is there a work around or anything that could be done?