Clean ROM DE 1.4 Issues: SD Card unmounted


New Member
Dec 1, 2009
Reaction score
Hi all,

I have the latest RUU (software v. 3.14.605...), am S-on, and hboot v 2.11, using Amon Ra recovery.

I tried to flash the DE version 1.4 today and all went fine, except for the SD card is not mounting/being detected properly. ANY suggestions?

What I tried already to resolve: total wipe and reflashing, reflashing again (no wipe), removing PH98IMG from SD. I did not use the GB patch (since I have the ICS firmware). Also, as long as the PH98IMG is on SD root, I can not get to Recovery and am stuck in Hboot (with prompt 'would you like to update' then 'reboot')... I dont know that this is normal as the directions say to put both ROM and PH98IMG on SD root.

Thanks in advance!
When you RUU'd did you run it twice? The first flash does the kernel the second does everything else. That SD card issue is indicative of not having the right firmware for the ROM.
I did go through everything twice with the RUU. The phone is displaying Android v.4.0.3 and software and was running on the RUU for a couple weeks with no problems.

That is why I am extra confused why I am having SD issues (as all SD issues appeared to be with GB users not using the patch).
Yes...Yes they do. Hmmm. Have you tried reflashing the kernel?

Yes, I did and no dice.

However, I went back to GB, used the GB patch and now CleanROM was running perfectly.

So, I decided to to wipe CleanROM, redid the ICS RUU, doble checked to make sure (again) that the phone was recognizing 4.0.3 and software 3.14, tried CleanROM again with the same results as before. So, now I'm back to GB with the patch. What the hell? I suspect I must be doing something wrong, I just cant figure out exactly what I could possible be doing wrong.