Cannot Flash Clockwork Mod Recovery

im having same problem and cleared my download cache and tried again like a previous post said to and that did not work either
I guess servers are down again? I'm having the same issue. xD

Nevermind, just started working again.
Last edited:
i got mine to work just by downloading the 2nd part of rom manager again. some how with all the switches it got uninstalled.
Koush's server with the recovery images was down, so Rom Manager would throw an error if you tried to flash a recovery which you didn't already have in the cache. I recommend that you don't clear your download cache, or at the very least save a copy of the latest recovery image. That way, if the mirror does go down again, you can simply copy that .img file to [sdcard root]\clockworkmod\downloads\\recoveries and be able to flash via Rom Manager.

The servers are back up though, so anyone having this issue should be able to download the Clockworkmod image and flash successfully.
I keep getting "an error occured while flashing your recovery" on sprecover or clockwork mod...what is wrong with this Junk I even paid for it.
I still can't get SPRecovery to work. But I just flashed ClockworkMod Recovery and it works. But the steps I took to get it to work shouldn't be necessary at all. I had to clear download cache, forget permissions on Superuser and restart the phone. After restarting, reflash ClockworkMod Recovery, grant and remember permissions and then restart the phone again. Sometimes it isn't necessary for me to restart after flashing, but I just do it anyway. Sometimes if I try to do something, like Backup Current Rom, it restarts my phone and takes me to the yellow ! screen. I'm guessing it does this because ClockworkMod Recovery fails and boots you into recovery to manually do a nandroid backup. But I press the power button to restart the phone. When it restarts I can try to do a backup. Sometimes it works, but other times it does the same thing. Then when I restart it again, it works.

This is the same with just about every function I use on Rom Manager. Such as flashing roms and kernels.

SPRecovery is almost non-existent in Rom Manager.. on my phone anyway. It serves no purpose other than taking up space at the bottom of the menu.
Those of you having problems with the flash failing, try clearing your download cache within rom manager and trying again.

Otherwise I have a guide for flashing any custom recovery manually at my site linked in my sig.

good luck