Cannot Connect to Twitter with Droid II


New Member
May 17, 2011
Reaction score
My wife woke up this morning and could not log onto twitter from her Droid II. The browser appears to start to connect and then it just stops and all she gets is a blank screen. We've tried clearing cookies and cache and resetting and turning off the phone and pulling the battery with no luck.

She can surf the net and google anything she wants but Twitter will not work. It looks a bit funny too as when you look at it in the search bar it has a little lock symbol.

Can anyone give me some hints as to what has happened? She's been on twitter with this phone for months now. All of a sudden it won't work.
Has she tried using a third party program, such as Tweetdeck, Seesmic or the like to access Twitter? I don't use the Twitter client that's installed on my Droid X. I use a third party app for it.
Cannot Access Twitter Mobile on Droid X Running Android 2.3.3

I have the exact same problem with my Droid X. Twitter Mobile has worked perfectly fine until I upgraded to Android 2.3.3 a few days ago. Now Twitter gets stuck on a white page of death.

My Twitter app works fine but I don't like it, nor do I want to use a 3rd party app. I want my Twitter mobile page back. All the other URLs I visit are fine too. Just Twitter. HELP!