Bluetooth connection problem with Ford Sync

heatmisr

New Member
Joined
Nov 19, 2009
Messages
19
Reaction score
1
Location
Northern NJ
Hello everyone. I have the Turbo 64GB and I'm having problems with the bluetooth connection in my 2010 Ford Expedition with Ford Sync.

The phone pairs with Sync, but the connection is not stable. When I turn the car on, the phone connects and then the connection immediately drops. If I manually reconnect the phone, it will connect, but their is no audio. Sometimes rebooting the phone will fix the problem, most times it doesn't. I have also tried unpairing and repairing it, but that didn't work either.

I spoke to tech support at VZW and Motorola and the solution from both is to give me a new phone. I know it is not the actual handset because I had the 32GB model originally and had the same problem.

Anyone else having problems with the Turbo and Ford Sync or have any suggestions?

Thanks in advance.

BTW: Upgraded from a Droid Maxx that worked perfectly with Sync.
 

crxlsturbo

Member
Joined
Oct 30, 2011
Messages
264
Reaction score
21
I have the same problem with my 64gig turbo pairing with my kenwood dpx500bt deck. My Droid Maxx had no issues pairing with it. On to my Turbo and I'm experiencing the same issues as you. My only solution was to scroll through the function options back to bluetooth audio on my deck and my sound comes back. I think it's a software issue more than hardware.
 

cr6

Super Moderator
Staff member
Joined
Apr 1, 2011
Messages
8,282
Reaction score
5,844
Location
NW Rocky Mtn region
Website
www.dronewolfmedia.com
Current Phone Model
Galaxy S7 Edge
Twitter
@dronewolfmedia
You would think in this day and age we wouldn't continue to have BT connectivity problems, but the fact is, there are still too many discrepancies with hardware. (And software for that matter) It's more than likely a compatibility issue with your vehicle and a new device is not going to make a difference. I've seen this very same issue countless times over the years across numerous phones and vehicles. You'll get much better results using a stand alone Bluetooth device.
I know that's not what you want to hear. Perhaps someone will have a better suggestion. Good luck!

S5 tap'n
 
OP
H

heatmisr

New Member
Joined
Nov 19, 2009
Messages
19
Reaction score
1
Location
Northern NJ
I'm thinking it is a software issue also, but trying to get Motorola or Ford to write a fix for it will be like trying to move a mountain. I actually think it is more Motorola than Ford since the Maxx works fine. Hopefully, they will get some complaints (Motorola)
 
  • Like
Reactions: cr6
Top