4G to WiFi and back issue


New Member
Aug 18, 2011
Reaction score
Playing with new phone this morning at my office. Switched to WiFi and then back to 4G it would not reconnect. Tried flipping it back and forth, no data, turned on airplane mode, then off again, nothing. Only way to get 4G acitive again was power phone off and then back on again, got data.

Any ideas out there?

Sent from my DROID4 using DroidForums
This happened to my phone today and with my boss' phone too. 4G was blue the whole time, I toggled Airplane mode on/off but no go. Like you, I had to reboot to get connectivity back.
I've had similar 3g issues, I have noticed, however, is that IP still works, just not DNS. for example, running an ftp program or ssh program via IP address works, but going to google.com in a browser does not. I wonder if anyone else is having similar issues.
It might or might not be related (because of the Wi-Fi component) but read my post here:


I saw that, I don't think it's my issue, however. Uppon further investigation, DNS is failing due to a timeout. I do see that my phone reports 5 blue bars and -84dbm/0asu when sitting in a spot that was dead to my old Droid X (and is currently to a coworker's Galaxy Nexus). I now suspect there may be an issue with the way the system is reporting data connections. Now that I think about it, I've never seen it below 4 bars, even in elevators and similar dead spots. Anyone seeing the same thing?
Experiencing the same problem... hadn't known it was happening; e-mails were coming in late, and I believe that's 'cause it was looking for wifi instead of switching/relying on ANY/ALL connections (3 or 4g) which were present.
Turning wi-fi OFF, and then rebooting has allowed my phone to connect 4g from my desk.

Is this a bug? Are these forums monitored? Will Verizon fix this/address it? How to make them aware. I've only had the phone (Droid 4) three days now.
Something else you can try (was suggested to me by one of the Verizon reps) is to go in to Menu-->Settings-->Wireless & Network Settings scroll down to the bottom to ''Mobile networks' and change the network from CDMA/LTE (4G) to CDMA (3G) and/or vice versa. It worked for my when I was getting bad 4G connectivity in a good 4G area but it didn't help my 3G swapping to wi-fi and back issues.
I have the same issue with my 2 day old droid4. Everything works fine with wifi but when I turn it off there is no data access. Rebooting did fix it.......for now.
If it's any consolation, it hasn't happened since that first time I encountered it.
Hello all,
Newbie? here...Same problems here. Been working on this issue since 2/13. On second phone now, Third one is on it's way. Was on a conference call with tier 2 Verizon tech and motorola Tech Tuesday night. Factory reset did nothing but lose my unsaved apps. They say they have no idea ???? They have had no issue with this. The kids Razer has Identical software, and Ginger 2.3.6 has not had a problem.... Neither is Rooted yet, BTW. And no 4G close by to test just 3G and lots of open and secure WIFI...Tried it all , NOT HAPPY with big Red....I will try #3 and then maybe root.....if all else fails I will be rockin the OG until recall, software update,or ICS...Thanks for letting me Vent!!
I started having similar problems and it required either a restart of the phone, switch 4G to 3G back to 4G again and got frustrated. I suspected it could have been related to a setting I tweaked in Llama or Smart Actions. I trouble shooted it to Smart Actions so I deleted all my events and created one for Charging that specified Cellular Data enabled. This fixed it. I've since gone back into my Smart Actions and ensured that this setting was being forced.
I'm a newb to the droid 4. I had my orig droid rooted with Sourcery. Nice OS. My problem is that I can't get any internet connectivity using mobile network (Verizon). I got this droid on Saturday (4 days ago), and it was in a city that had 4LTE access. I live in an area that is 3G at best. It worked fine until yesterday, and I noticed at work that I had not access. I only have access using mobile network at work, can't use internet at work (idiots, I know). I tried everything I have read so far. It includes this link from above: Droid4 Not sending or receiving data (or intermittant) when connected to Wi-Fi (3G) I saw another post that suggested that I power down and remove my SIM. That didn't work either. A few posts said to use some 3G monitoring tool, but I am getting NO 3G connectivity, so ZERO is all that it showed. ;) I need 3G at least. I was aware when I bought the phone that I wouldn't have 4G, but no one said I wouldn't have ANY internet. I'm thinking of heading into the 'home zone' after work and dialing #288 (or whatever it is) and reload from here. Maybe that will help. I'll let y'all know what happens.

I'm not real happy with big V at this moment. :mad:

Almost forgot, I made sure that I had my Enable Auto IP was turned off. It was.

K - went to home zone, and I got 3G right away. I still did the *228. It went really fast, so I'm not sure what it did. I came back home, lost 3G right at border (where it normally switches to extended network). Went back to home zone, pulled SIM card, *22880, and *22890, 3G still. Back in home zone (extended network) - NO 3G (no network at all when I state no 3G in this post. NO mobile internet). I'll head over to our local collection of cell phone idiots and see what lies they can tell me tomorrow.

All you experts can help me at any time.
Last edited:
I don't know what's causing your issue. However, I can tell you that dialing *228 on an LTE phone is pointless. The network automatically pushes the information (and any updates) to the device while an active SIM is installed.
I'm never sure, and I KNOW that Verizon doesn't really know either. I try to do anything and everything I can to hone in on the real issue. I'll bet you DINNER that they try to factory reset my phone when I go over there. Further, it won't work. We'll see. I'm doing a backup of it all before I go over there.


We have not yet begun to fight!

So, local office oblivious. Call tech support. One hour of doing less than i had already done, and i get a trouble ticket. That was Thursday. Support person is going to call me back on monday. They think it is a localized issue. Weeeeee this rollercoaster is fun!

OK. So Saturday, technical dude sees that I am on the network (which I am, in a 4LTE area 60 miles away from my issue), and leaves a message that it must be fixed. Let me know if I have any other issues. I call Monday, and the tech is pretty good. Acknowledges that the previous tech is a buffoon (basically), and he is sending me a new SIM card as that can be the problem. I don't think so, but I know how this stuff goes. He DID say something interesting, though. If you perform a #228, blah blah too many times (like 2-3), it screws up the SIM card. So, yet another misinformed tech support dude. So...the struggle to get what you paid for continues. Note to self: Call and do NOT pay for mobile network this month. :)

(oh, and NO call from the nice support person as promise above - figured)
Last edited:
Solved!! :)

Good news! They sent me a new SIM card. I pulled it in the home zone. I had to get Verizon to update my account with the new sim number (I should have done it first, but not near a computer to do so). It worked!

I drove home, into the extended zone, and I have 3G. Sweet!

Thank you Verizon technical support