USB audio?

Discussion in 'Motorola DROID Turbo 2' started by fast_eddie_72, Apr 14, 2016.

Tags:
  1. fast_eddie_72

    fast_eddie_72 New Member

    Joined:
    Apr 14, 2016
    Messages:
    8
    Likes Received:
    7
    Trophy Points:
    3
    Ratings:
    +7
    Current Phone Model:
    7204044083
    I just upgraded from a Droid Maxx to a Turbo 2 with Android 6.0. On my Maxx, I could use external USB DACs, but no luck so far with my Turbo 2. It doesn't act like any other phone I've tried. It just doesn't seem to recognize that anything has been plugged in. For instance, I have a USB DAC with a headphone amp. On some android devices, like the LG tablet I use, it works great. On others, as soon as I plug it into the phone with an OTG cable, the phone will shut off. But with the Turbo 2, it just does nothing. First time I've seen that. With unamplified DACs, it just ignores that they're plugged in and continues to play through the speaker.

    Is there any setting available to enable USB audio? I would really hate to lose this feature.

    Thanks
     
  2. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,643
    Likes Received:
    6,745
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,248
    Current Phone Model:
    Moto Droid Z Force
    I am not familiar with any Setting anywhere on the phone that would affect that. I had never heard of DAC until I read your post and looked it up online.

    Sent from my XT1585 using Tapatalk
     
  3. fast_eddie_72

    fast_eddie_72 New Member

    Joined:
    Apr 14, 2016
    Messages:
    8
    Likes Received:
    7
    Trophy Points:
    3
    Ratings:
    +7
    Current Phone Model:
    7204044083
    Sorry, external USB Digital to Analog Converter. I was able to get pretty amazing sound from my Maxx playing lossless (FLAC) files with an external DAC. Whatever is in the Turbo 2 is better. The sound coming straight from the headphone jack is improved over the Maxx, but I would love to be able to use my DACs.
     
  4. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,806
    Likes Received:
    4,751
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,290
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    Looking as well. I know it was supported on earlier phones as you mention, buy no word either way on this one.

    Sent from my XT1585 using Tapatalk
     
    • Like Like x 1
  5. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,643
    Likes Received:
    6,745
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,248
    Current Phone Model:
    Moto Droid Z Force
    I wonder if it was an oversight on Motorola's part? Or a feature that they decided to no longer support? Hopefully FoxKat will find the answer.

    Sent from my XT1585 using Tapatalk
     
  6. fast_eddie_72

    fast_eddie_72 New Member

    Joined:
    Apr 14, 2016
    Messages:
    8
    Likes Received:
    7
    Trophy Points:
    3
    Ratings:
    +7
    Current Phone Model:
    7204044083
    I found this, and seems to have some info that may help solve the issue.

    Inside Marshmallow: USB connection options

    So I just plugged my Turbo 2 into my computer and indeed I get a selection box. And it has the "Just once" or "Always" option as well. So maybe changing this will do it, but I'm at work and don't have my DAC here.

    Default choice is "Charge only". So that's why it's not doing anything.

    Other choices are Transfer Files (MTM) Transfer photos (PTP) MIDI and Software Installation.

    I'm just not sure what to select, and if I do something and chose "Always" how do I change it? Very confusing.
     
    • Like Like x 2
  7. fast_eddie_72

    fast_eddie_72 New Member

    Joined:
    Apr 14, 2016
    Messages:
    8
    Likes Received:
    7
    Trophy Points:
    3
    Ratings:
    +7
    Current Phone Model:
    7204044083
    Also just found this. Tap the build number 5 times to get in developer mode. The developer menu has a selection for "Disable USB audio routing" but it is set to off. I'll play with it more tonight when I get home and have my DACs.

    You Can't Set MTP as Default Connection on Marshmallow
     
    • Like Like x 2
  8. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,806
    Likes Received:
    4,751
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,290
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    I'm seeing mention of USB audio working with the original generation Turbo on a Motorola developer site, but have yet to find anything mentioning it working with the Turbo 2.

    The justification seems to be that USB audio support has been spotty with earlier versions of Android and with various phones, so it may have been a decision to no longer support it since it has been problematic.

    Sent from my XT1585 using Tapatalk
     
    • Like Like x 1
  9. fast_eddie_72

    fast_eddie_72 New Member

    Joined:
    Apr 14, 2016
    Messages:
    8
    Likes Received:
    7
    Trophy Points:
    3
    Ratings:
    +7
    Current Phone Model:
    7204044083
    Yeah, I'm thinking it got messed up with Android 6.0. The hardware should do it, but this default to USB charge only is probably preventing it.

    But I couldn't find anyone using USB audio on a Turbo 2 either. Which seems weird. I could find lots of information about my Maxx. I know people use that feature, and the Turbo 2 had been out long enough, you'd think someone would have posted something somewhere.
     
  10. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,643
    Likes Received:
    6,745
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,248
    Current Phone Model:
    Moto Droid Z Force
    I'd you ever need to clear those Once / Always app choices go to Settings > Sound & Notification > App Notifications > Menu (3 dots) > Reset App Preferences.

    It will clear all choices though, not any one specific app preference.



    Sent from my XT1585 using Tapatalk
     
    • Like Like x 1
  11. k1601

    k1601 Senior Member

    Joined:
    Apr 24, 2015
    Messages:
    113
    Likes Received:
    58
    Trophy Points:
    83
    Ratings:
    +60
    Just FYI, my turbo 1 wont play audio through USB on my head unit in my pickup. It says something along the lines of device not readable or something. Bluetooth also doesn't work (radio manufacturer says my Android build is too new/radio too old)

    Sent from my XT1254 using Tapatalk
     
  12. fast_eddie_72

    fast_eddie_72 New Member

    Joined:
    Apr 14, 2016
    Messages:
    8
    Likes Received:
    7
    Trophy Points:
    3
    Ratings:
    +7
    Current Phone Model:
    7204044083
    Okay, it's a PITA, but I got it working. In Developer Options (Explanation on how to get into Developer mode above) there's a selection for USB configuration. With my headphone DAC/Amp plugged in with a host cable, "Audio source" was an available option. But it did take a few tries to make it work. But I am glad it is possible at least.

    (edit) It does seem you have to do it each time. Still working out the correct sequence of events to get there. Yeah, a pain, but better than nothing. Sure was easier on my Maxx. However, the USB DAC with the headphone amp didn't work on Maxx. So ultimately, I can finally do what I really want to do, but it is a bit of a pain. #FirstWorldProblems
     
    #12 fast_eddie_72, Apr 14, 2016
    Last edited: Apr 14, 2016
    • Like Like x 2
Search tags for this page

droid turbo 2 with external dac

,

how to use a usb dac with droid turbo 2

,

motorola droid mini audio source developer mode

,

what is the disable usb audio routing