Trouble resetting my tablet

Discussion in 'Android Tech Support' started by eitsirk, Jul 16, 2015.

  1. eitsirk

    eitsirk New Member

    Joined:
    Jul 16, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    NATPC MO10SE Tablet
    I have an NATPC MO10SE 4gb (4.0 Ice Cream Sandwich) that is stuck on the boot screen.

    I have tried:

    - the volume/power button combination, in every variation - no result.
    - downloading Multi Tool to do a data wipe via usb - but my laptop doesn't detect my tablet, even though it shows up in the Device Manager (but not Disk Management) and the Safely Remove Hardware icon appears, and I tried updated the driver software but "software is up to date."
    - Running the battery down - I get the desktop screen for a second and then it disappears as soon as I plug the charger in (the desktop background remains, just the apps and shortcuts and icons etc disappear.

    The only thing I haven't tried is flashing it. Because I don't know where to find the firmware.

    Why whhhyyy is the button combination not working??
    And why won't my laptop detect the tablet?

    [​IMG] Help.