Motorola/Verizon Droid -- cannot 'select time zone' for Arizona

Discussion in 'Android Tech Support' started by quakermel, Mar 2, 2010.

  1. quakermel
    Offline

    quakermel New Member

    Joined:
    Mar 2, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hello all from newbie to Droids and this forum, Melissa. I live in Arizona, the only state with no Daylight Saving Time. And there is my problem.

    I noticed an issue in the installed calendar app linked to my Google mail/calendar. Recurring and other events that I set up have the wrong time associated with them after the change in daylight saving. I went to Settings | Date & Time | and unselected Automatic (Use network-provided values), then went to Select Time Zone and tried to switch it from "Mountain Time" to "Arizona". Try as I might, the change didn't stick. I've checked to see if the problem might be in my Google mail/calendar settings, but it's got me correctly in the Arizona time zone. When my Droid syncs back up with the calendar on my laptop, the times show correctly again. In other words, the incorrect times show only on my Droid.

    Am I correct in assuming that the network-provided value is what is telling my phone I'm in Mountain Time instead of Arizona Time? (It's true that for part of the year, we are the same time as Mountain Time, but the rest of the year we are on Pacific Time, and picking Arizona Time should account for that automatically and seamlessly.) Why can't I make that change manually through the Settings menus?

    Does anyone have an answer or a workaround?

    Thanks,
    Melissa
Search tags for this page

android cannot select arizona time zone

,
android time won't change from mountain to arizona time
,
how do i set the time zone to arizona on my android
,
select arizona time zone on android
,
select time zone on my android
,
verizon arizona time zone