How to get my contacts name to show up when they call me?

Discussion in 'HTC Droid Eris' started by Sappie, Mar 15, 2010.

  1. Sappie
    Offline

    Sappie New Member

    Joined:
    Mar 15, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Texas
    i just recently upgraded from my BB to the ERIS and I'm trying to set up my phone and add all my contacts but when my Huband calls me it always shows up as unknown caller even though i have his info saved in my contacts list. Can some one help me figure out what I'm doing wrong b/c I will never answer the phone if I don't know whos calling me. lol
  2. droider4life
    Offline

    droider4life New Member

    Joined:
    Dec 28, 2009
    Messages:
    463
    Likes Received:
    0
    Trophy Points:
    0
    On my Droid I had this problem... I don't know if the eris is the same or not but make sure the phone number is under the correct label mobile/home and try taking the number 1 off the first if the number. ... see if thus fixes ur problem.
  3. LtKen
    Offline

    LtKen New Member

    Joined:
    Jan 27, 2010
    Messages:
    2,637
    Likes Received:
    1
    Trophy Points:
    0
    Yeah, removing the 1 from US numbers should fix this. The call label (home/work/cell) shouldn't make a difference.

    If you have the number in as 1-AreaCode-Number, the cell recognizes incoming calls as AreaCode-Number, so since they dont match, you wont get the link to contacts.
  4. Sappie
    Offline

    Sappie New Member

    Joined:
    Mar 15, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Texas
    I tried it and it didn't work. lol I don't think there was ever a "1" along with the number in the first place. lol
  5. droider4life
    Offline

    droider4life New Member

    Joined:
    Dec 28, 2009
    Messages:
    463
    Likes Received:
    0
    Trophy Points:
    0
    Actually the label did cause some grief for me.. I Had some mobile numbers labeled as home and it wouldn't show the info.. it was weird. Changed the label and fixed my problem..
  6. Sappie
    Offline

    Sappie New Member

    Joined:
    Mar 15, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Texas
    Come to find out it was an issue on Verizon side, the option for Caller ID wasn't selected and once they fixed that it works like it should. lol Simple issue and it took me 6 hours to come to a conclusion. haha All is right in my world now...on to tackle other things with this. This is for sure a bigger learning curve than my BB was.

    Thanks so much for the suggestion and trying to help yall. =D
  7. droider4life
    Offline

    droider4life New Member

    Joined:
    Dec 28, 2009
    Messages:
    463
    Likes Received:
    0
    Trophy Points:
    0
    Ha ha ha that's funny! Glad u got it fixed up: )
  8. loves2laugh
    Offline

    loves2laugh New Member

    Joined:
    Feb 11, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Mine is doing it too, but only with some of the numbers. Some names show up and some numbes show up. It's very frustrating. It's like the old days when we had to answer our phone even though we didn't know who was calling us!! LOL How terrible!!! LOL
  9. mamawm
    Offline

    mamawm Member

    Joined:
    Jul 30, 2010
    Messages:
    509
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    mississippi
    as stated above make sure the contact #'s are correctly labeled. if you receive a call from a landline and it is set up in your contacts as a mobile #, only the number will show up, not the contact's name. and the other way around too. once you've fixed those labels the contact names should show up. (i know all this because of past experience)
  10. RCFlyn
    Offline

    RCFlyn New Member

    Joined:
    Jun 2, 2010
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    N.Y.
    I've never had any problems with the contacts being placed in the wrong catagory (I.E. Mobile, home, office) making any difference, but I have had an issue a time or two, where the "1" either being in front of the Number or not, making a difference. Oddly enough, some #'s have to have the "1" in front, some #'s are fine with just the Zip code & Number being enough... :unsure:
Search tags for this page
how can i show the contact name on an incoming call for a droid maxx
,

how do i get my contacts name to show on my blackberry when

,
how do i get my iphone to show the number that is calling
,
how do i get my name to appear when i make a call on moto g
,

how do i see the name of the person calling me if the contact is not stored on your phone

,
how to fix windows phone not showing names when a call comes up
,
how to get contacts to show up on htc
,

how to get contacts to show up when getting a call

,
how to have names show up when they call on iphone
,
only display name during call on android