GOT openrecovery question

Discussion in 'Motorola Milestone' started by shiyou, Jul 20, 2010.

  1. shiyou
    Offline

    shiyou New Member

    Joined:
    May 29, 2010
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    hey guys
    im running stock android 2.1 (not rooted) on my milestone with SHOLS_U2_2.31.0 and i want to install the GOT openrecovery 1.04a
    do i need to have SHOLS_U2_2.36 orso first to install GOT openrecovery 1.04a? or do i need to flash a sbf file first? or am i good to go in my situation?
  2. Daeymon
    Offline

    Daeymon New Member

    Joined:
    Apr 26, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Don't quote me on this, but I believe you need to flash the apprioate region firmware (sbf), also available from their site. All the scripts the Open Recovery provides are designed for those firmwares, so using others could result in instability.
  3. ashketchum
    Offline

    ashketchum New Member

    Joined:
    Jun 25, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    The sbf files provided by GOT are just leaked versions with the vulnerable recovery included.

    If SHOLS_U2_2.36 is officially available for your phone then you should install it. It may be available through an OTA update. If not you can check this page to see if there is a SHOLS_U2_2.36 sbf available for your milestone. Check the "2.1 (Service version)" section. In my case its the south-east asia version and its officially available so there is a link to download the official sbf file from Motorola's website. If there is an official sbf available for your region and you choose to flash it, then you will have to flash the vulnerable recovery separately. You can find the download link for the vulnerable recovery at the end of that page.

    You can install GOT's OpenRecovery after flashing the vulnerable recovery.
  4. Eggos
    Offline

    Eggos New Member

    Joined:
    Mar 13, 2010
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Ontario, Canada
    To be able to use the open recovery, you just need to have flashed a vulnerable recovery. This can be the one over your current,stock rom or GOT (that has it in it).

    Sent from my Milestone using Tapatalk
  5. chad_petree
    Offline

    chad_petree New Member

    Joined:
    Jun 16, 2010
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    0
    my phone shows shla_u2_03.05.0

    SHOLS_U2_02.36.0 is newer than mine, right?

    my phone works in 850/1900/2100 bands and i checked and the thai version has
    SHOLS_U2_02.36.0 can i flash it withouth problems?

    was the alarm problem fixed in 2.36.0?
    Last edited: Jul 21, 2010