Wired Headset/Mic


Feb 17, 2010
Reaction score
Hi All,
Previously I had been using an older Apple headset/mic with my OG Droid and Bionic..until it got stuck in my car seat and got chewed up..
I finally got around to buying a new Apple headset/mic..This one however, has the remote buttons on the Mic port.

I know that the remote buttons wont work..Not a problem..however, the Mic is not working.

I tried the headset on my OG and my wife's Incredible and the Mic works fine.

I could swear the old headset was working on my Bionic as no one ever complained about not hearing me.

A few weeks ago I did a factory reset as a "housekeeping" procedure...I was bored. I cannot say if my old headset worked or not since then as I don't think I used it.

Before I try a factory reset and waste another 3 hours, I was hoping to see if anyone else has been using the "newer" Apple headset (with the remote clicky things on the mic).

(yeah yeah yeah..I know Apple sucks...but they are the only earbuds I find comfortable.)