wallpaper save problem


New Member
Nov 17, 2009
Reaction score
Regarding my new Moto Droid on Verizon.
Hey folks, just a quick question, I've got some wallpaper / background apps. I saved some to my phone card on sites where there are pictures and there is an option to save images. The thing is they dont show up in my wallpaper folder or my picture folder. But, if I shut the phone down then power it back on, they appear in the picture folder. The folder is fine, but just really dont want to have to shut down the phone everytime I get a new wallpaper. any ideas as to why this is happening? Is there a way around rebooting the phone everytime to see the new wallpaper? Again, this is if I am saving via a direct link that says save as wllpaper, not if I hard press the actual picture and then save it.

Thanks for your help, hope all is enjoying this new.
I'm seeing them in the pictures list as soon as I save them. I'm using this process -

1) Find a picture I like on the web.
2) Click and hold on the picture. Save.
3) Go back to the homepage.
4) Go to menu > wallpaper > pictures.
5) click the picture I just saved.

I've never had to shut down the phone. Are you connected to your computer via USB while this is happening? While you have a USB connection mounted on your phone the SD card won't work as expected from the phone.
to clear up things

. thanks for replying, i think i may be confusing you. When i do it just like you describe, it is fine. However, a couple of apps ive been using, like "amazing animals" and "nasa images", pretty sure it was those two. it does not give you the option to hold on the pic then save to pics. you have to hit the menu button and choose to either download or save as a wall paper. then when i close out the app, its not in the folders. I turn off phone then they appear after a reboot. And no, the phone is not connected to my pc. But I did check my phone after I mounted it to my pc and noticed after i disconnected some pics popped up without the reboot step.

Odd, but the phone is awesome!!!!