Voicemail icon in notification bar


Nov 7, 2009
Reaction score
Philly Burbs
I use Google Voice for all my voicemail so I don't know how the voicemail notification icon appeared. But now that it is in my notification bar I cant get it out. I don't have any voicemail waiting I even called into my Verizon VM to confirm. It is driving me crazy and I cant see to get rid of the icon. I don't think it matters but I am rooted and running Bugless Beast 1.0. I have tried to do a complete backup and restore, but the icon pops back up. Any suggestions?!
Leave a message in VZW's voicemail system. Then delete it.
Don't know if it's the same issue, but that happened to me twice. Ended up that it was caused when I left another VZW user a voicemail and when he listened to it, he chose to reply to the message through their system. (Instead of hanging up and calling me) That put the VM in my VZW's voicemail instead of forwarding to GV's VM. I had to turn off forwarding and dial *86 to listen and delete, and then turn forwarding back on.
... Wait, ya'll have a voice mail indicator? I've never seen one, I just get those obnoxious "You have visual voice mail" text messages.
That was it guys, thanks for the help. I had to actually disable GV in the app and I also had to dial *73 to deactivate GV. Called my VZW Voicemail and deleted the new message. Icon went away and I am back on GV!

Thanks again!