voice recognition goes to a foreign language


New Member
Feb 1, 2011
Reaction score
My voice recognition was working fine until I used Google Navigate. Ever since then it (Voice recognition in text messaging app) appears to be translating into spanish? ("Testing, hello, hello, hello," became "casting cavour".) I went into settings and selected English, US, which it was already on, but that hasn't helped.

Any advice?


ps. the voice recognition in google navigate works perfectly.
pps. I'm using a one month old LG Vortex with Android 2.2.1
I just switched to English (Generic), and it doesn't appear to be doing Spanish anymore, but it's still all funky. "Help with voice recognition" becomes "web whois". "The rain in Spain stays mainly on the plains" becomes "wingdings einstein memoria ram phoenix". When I go into google navigation and speak my mom's address, it gets it exactly right.
swype effects speech recognition

It was my freakin' swype settings. They'd been switched to Spanish. Since that takes four clicks, I'm sure it didn't happen by accident. I also have no idea why swype would effect my voice recognition. It's not intuitive, and if I hadn't tried writing with swype (you know, to speed things up since my speech recognition wasn't working), I never would have guessed that was the problem.

Hopefully this thread helps some other poor sap in the future!
voice recognition now types into Spanish

This works! Same issue, in my text app the voice command kept spitting out spanish... the swype language somehow was switched to espanol.

Thank you!
Voice to text in different language solved!

THANK YOU!!! SOLVED. Swype settings were set on espanol. So random...who would have thought! Main Menu>Settings>Language & keyboard>Swype(Swype Settings)>Laungauge. Wow, finally... Droid x2 with Handcent. Like you said, hope it helps some poor sap. Chalk me up.
this problem has been vexing me for a long time. THANK YOU.
frikin' swype.
Thanks for the information, I thought I was turning Spanish. :p

Swiper no swiping.
Me too! And thanks for the soluition!

I'm that poor sap.
Thank you!
The identical thing happened to me. I recalled later that some window appeared unbidden while I was using voice recognition to text-message and that I just dismissed it, noting only that the word "English" appeared in it. Only when I next texted did it start interpreting my speech as Spanish. I went all the way down to pulling the battery, but nothing helped. I would never have guessed Swype was involved (and I agree I certainly didn't do anything to open the Swype settings).
Anyway, I joined this forum just so I could say thanks.
--al sicherman