USB Issues


New Member
Jan 9, 2011
Reaction score
Hi All,

I'm having issues with the USB in my D2G.

It's been rooted with Z4 root.
It's the stock ROM.
Android version 2.2
Baseband N_01.48.05r
Build VZW

I have Titanium Backup Pro that I used to freeze the bloatware. Currently USB Debug is enabled.

The charge mode & SD card modes of USB work fine when I plug it into my laptop. The Wyndows Synch & PC modes don't work. The PC says it can't load the MTP USB Driver. I went to motorolla & loaded the 4.8.0 version of the drivers.

I've tried them with the USB debug off & on.

The issue is that I can't access the SD card when plugged in SD mode, and if I try to start TiBackup it of course doesn't work. (GREAT program btw, highly recommend it.)

Also, periferal question...does USB debug have to stay enabled as long as I'm rooted? TiBackup message says it doesn't need to be on later Android systems.

Not really a major issue, but its a little annoying. Thanks for the help!

I am not positive, but I think you have to install the Android SDK on ur laptop before PC mode works. Also the SDK will install proper drivers for PC mode to recognize ur phone. Has something to do with ADB o phone and computer for them to communicate.
Am pretty sure USB debugging has to be on all the time,

Sent from my DROID2 using DroidForums App
Downloaded the SDK & the USB drivers & followed the install instructions, but when I try to update the USB drivers it says that the install package isn't valid for 64 bit windows.
The best workaround I have come by so far is just to keep USB in charge only mode. If its in USB mode then none of the custom ringtones or anything stored on the card works.

When I need to upload stuff from the laptop I toggle it.

As an alternative does anyone know a way to copy stuff like ringtones etc from the card to the actual phone memory?
With root explorer you can access the phone's internal memory, so I've read. I've never used it myself.

Edit: I'm sure with ADB you can access it, but I'm not familiar with it, myself.
Yes & no lol. Yes, the sdk got ADB to work, the google USB drivers work, got PC mode working, all that good stuff. Which of course turns out didn't get me what I needed!

What I was trying to do was be able to have the Droid plugged into the laptop, and be able to access the SD card on the laptop & the Droid simultaneosly. When is SD mode none of the ringtones or settings are accesable on the Droid, and when in charge mode I obviously can't synch.

When I was on the old version of droid from VZN & I plugged in the phone, a Droid appeard in devices which gave me that capability. When I double clicked on it I had a wondow pop up that let me do all kinds of stuff.

Now I get 5 devices for mass storage, ATP, ADB, etc...all generic icons. Double clicking on them just gives the drivers properties window as opposed to the window I used to get that had options to Synch, Backup, etc etc.

When plugged in PC mode, all the drivers load but nothing appears. Basically, no application in windows (7 ultimate x64) recognizes the droid as a droid, only as a mass storage device.

Any ideas would be greatly appreciated.
I will have to take some time with this. The Global version of D2 is diffedrent. I will get back to U. In the jmeamtime what do U mean "old version of droid."
By old version I mean that when I got the phone & plugged it in & set it up it worked like that, then there was a verizon update that ran. Thats when it stopped working. (I don't know what they updated, they don't like to tell you that stuff.) It was through the check for updates menu.

That's when it stopped acting that way. That lead me to the updated moto drivers 4.8.0 and then finally to here. Where I got to do all this other cool stuff.

BTW, , tried it on 2 other machines with Win 7 ultimate x64, clean as in reverted everything to stock & redid the process, and they never came up as a "Droid" device in windows.
And no rush, right now I toggle from charge only to Remote Storage mode manually & copy things back & forth as I need them. I appreciate the effort!
Ok, I'll do some searching. Btw look in the D2G forum. I am sure U posted this in the "old D2" forum. Ha. I will get back tomorrow.
Think of the sd card as a thumb drive, its either plugged into your phone or plugged into your pc, don't believe you can have both since it has to be mounted in one place or the other
When plugged in PC mode, all the drivers load but nothing appears. Basically, no application in windows (7 ultimate x64) recognizes the droid as a droid, only as a mass storage device.
That is the way it works. If you want to see "internal memory in the phone" you have to go into an ADB Shell and browse the folders/files.

I took some screen shots on my computer with the D2 in PC Mode and mass storage mode so you can see what I am looking at.

Your description is not what I see so, I have a hard time understanding.

In mass storage mode you see the SD card as a Drive with all of its files and folders and you can copy/paste from phone or computer or computer to phone SD CARD.

If my screen shots don't make sense to you, then make some of your for me to see.
Makes perfect sence, that's exactly what I used to get, not anymore. There is no Droid device anymore in Devices & printers anymore, now I get 5 different devices listed under "unspecified" ,

Motorolla Communication Interface
Motorolla Networking Interface
Motorolla MTP Interface
Motorolla ADB Interface.

Clicking on any of those devices brings up only the control panel window with the properties tab on it.

The Mass Storage mode works fine, that gives the the SD card on the droid listed as a drive on my computer.

PC Mode gives me no access to the droid at all except through a CMD prompt where its listed in ADB.

OK, here's the fix...

I cleared the cashes on the phone, restored the original sbf & started again.

Loaded the 4.8.0 Moto drivers

I went through all the setups & the USB worked fine in all SDK necessary.

Then I did OTK update & everything still worked ok.

The problem is have to do the first plug in of the Droid with the original Android system. Then you can do the OTA update. If you do all the updates FIRST, then plug into the pc for the first time is when it fails to recognize the device.

As best as I can figure there's file missing in the cashe when you do the OTK to v33 that are in the original.

Viola. I thank you all for your help! If anyone else is having this issue & needs more detailed step by step instructions, just let me know!