USB "internet connection mode" no longer working?


Jul 18, 2010
Reaction score
I swear that I was able to use USB tethering with the "Internet Connection Mode" yesterday. But, now when I select "Internet Connection Mode" after connecting via USB to my laptop, I immediately lose 4G or 3G service on the phone. Then, I can't even browse the internet from the phone until I reboot the phone...

Anyone else experiencing this?
Same problem here (HTC Thunderbolt) and Verizon technical reps didn't have a clue (spent 2 hours on the phone with them yesterday).
I had sort of same issue first time tried it, I think in the ICM you can't talk and be online on computer sametime, thus some sort of collision with the dat/voice service on the phone until I rebooted phone....I support BB's and they will have voice but will lose their data part until pull battery, not sure what issues was, that's why I'm using the PDAnet app, even if have to pay later, you can talk, be on line works fast enough for me.
Kinda unrelated question, but does anyone know if the ICM will incur a charge after the free hotspot promo expires?
This I posted another place why I think will charge

I looked at my Verizon Account and I have to think that the Internet Connection mode will cost you if you use....maybe after 15 May, I know the Hot Spot free until 15 May, but are they combining that with ICM.....See the photo, how the unlimited is separate?

Thunderbolt USB Connection Problems

Have had similar issues. On desktop PC (P4 2.88 Mhz 1Gb RAM) both Verizon drive and removable drive showed after connecting USB data cable to phone. Was able to successfully transfer music, pictures and ringtones. Then installed HTC Sync and Verizon Media Manager and nothing has worked correctly since then. Despite uninstalling / reinstalling / uninstalling both programs, connection of USB either crashes PC to BSOD (on recovery, error message mentions USB hub problem) or renders it unresponsive until cable is removed. Have tried this with HTC enabled / disabled, connect to sync / disk drive, USB debug enabled / disabled.

Last night, connected phone to laptop without installing any drivers or programs. Phone recognized immediately and I was able to back up contents of "both" drives. 2nd connection resulted in disappearance of the Verizon drive. 3rd connection showed Verizon drive as a CD drive rather than a removable drive.

My guess is that the Thunderbolt USB driver is not ready for prime time.

Any other ideas would be appreciated.