Ultimate Ears 500vi mic no workee DroidX


New Member
Mar 14, 2011
Reaction score
Hi all,

I purchased Ultimate Ears 500vi for use with my Verizon Motorola DroidX. They sound great for audio but the microphone does not work at all... no answering calls, voice command, etc.

Have tested other devices and they work fine with no config so it's not the handset.

I've tried the unit on a friend's iPhone (the 500vi is made for and marketed to iPhone users) and the mic works fine there. I've tried a different (cheap & sounds like crap) wired headset on the DroidX and that works fine.

Verizon store guy tested and told me what I already knew.

Logitech (they own Ultimate Ears) is no help... says 'contact the provider of your Motorola DroidX for a better guide on configuring the earphone within there gadget'.

I tried to dig around for settings in the droidx but found nothing that helped.

I think the controls on the microphone remote (play/pause, song back/forward, volume up/down. etc.) may not be compatible with DroidX.

Am I missing something here? Any insight/help/comments?

Thanks all.