Stuck in Tranquility 3.7 without Recovery


New Member
Jul 28, 2011
Reaction score
Fairbanks, AK
Hello. I have a Motorola Milestone X running the TranQuility 3.7 Rom. Unfortunately, I can't get my phone to boot into clockworks Recovery. I have tried several different methods, but I just get stuck at the Tranquility boot image until I do a battery pull. I had used the Droid X bootstraper; I also tried the Droid 2 Bootstrapper to no avail. Trying to reboot through the Clockwork Rom Manager or the Tranquility toolbox also causes the phone to hang at the boot loader. I have tried forcing CWR by holding the volume button on power up and pulling the battery during charging with the same results.

If I hold the home button and power the phone boots into the basic android recovery, not sure if that helps. I tried wipe/reset, but no luck. Since it boots to this screen can I install Sprecovery some how?

I am not sure where to go from here. There are no full SBF's available for my phone with a proper baseband (Milestone X on Alaska Communications Systems). I found several other carrier SBFs on the web when I had trouble with my first phone, but lost all data connection. Anybody have any ideas? I rather dislike Tranq, but don't want a paperweight or data-less phone.

Does anyone here know anything about this SBF:
Android 2.2.1 System Version 2.3.340 System Only (SHADO_X6_2.3.34_SYSTEM-ONLY)

What exactly does it do? Other SBF's will alter the baseband so I could no longer receive data. Would this fix my milestone(approximately, I know this sbf is for a Verizon droid ) without rewriting my data, radio, etc.

***update*** Attempting to use Adb shell, but I am getting a no such file or directory errors when I try to flash" #flash_image recovery /sdcard/recovery.img. Can't figure out why besides I must be doing something stupid.



Silver Member
Sep 29, 2010
Reaction score
Sorry I didn't see this yesterday. Glad you got it fixed though.